summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-25 21:17:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-25 21:17:36 +0000
commitd1ad1f753af9a9768c3ddea66f17e9548062c8fd (patch)
tree8a87fd1451481b167a0212a168bd6ac9f8d7af31 /dev-util/pida
parentBump to 0.21, fixes #266427 (diff)
downloadgentoo-2-d1ad1f753af9a9768c3ddea66f17e9548062c8fd.tar.gz
gentoo-2-d1ad1f753af9a9768c3ddea66f17e9548062c8fd.tar.bz2
gentoo-2-d1ad1f753af9a9768c3ddea66f17e9548062c8fd.zip
Small fix for python paths. Fixes #262349. Ebuild fixes by Douglas Anderson.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/ChangeLog10
-rw-r--r--dev-util/pida/pida-0.5.1-r1.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-util/pida/ChangeLog b/dev-util/pida/ChangeLog
index ac6dad043ddc..5da194eb3a76 100644
--- a/dev-util/pida/ChangeLog
+++ b/dev-util/pida/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pida
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.18 2008/11/26 11:42:24 welp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.19 2009/04/25 21:17:36 patrick Exp $
+
+*pida-0.5.1-r1 (25 Apr 2009)
+
+ 25 Apr 2009; Patrick Lauer <patrick@gentoo.org> +pida-0.5.1-r1.ebuild:
+ Small fix for python paths. Fixes #262349. Ebuild fixes by Douglas
+ Anderson.
26 Nov 2008; <welp@gentoo.org> -pida-0.5.0.ebuild, pida-0.5.1.ebuild:
Remove old. Add librsvg dependency; bug 215501
diff --git a/dev-util/pida/pida-0.5.1-r1.ebuild b/dev-util/pida/pida-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..3baf427a2334
--- /dev/null
+++ b/dev-util/pida/pida-0.5.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.5.1-r1.ebuild,v 1.1 2009/04/25 21:17:36 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils eutils multilib python
+MY_P="PIDA-${PV}"
+
+DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
+HOMEPAGE="http://pida.co.uk/"
+SRC_URI="http://pida.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="gnome"
+
+RDEPEND=">=dev-python/pygtk-2.8
+ dev-python/gnome-python
+ gnome? ( >=dev-python/gnome-python-extras-2.14.0-r1 )
+ >=x11-libs/vte-0.11.11-r2
+ >=dev-python/kiwi-1.9.1
+ >=app-editors/gvim-6.3
+ >=gnome-base/librsvg-2.22.2"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc8-r1
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if ! built_with_use x11-libs/vte python ; then
+ eerror "x11-libs/vte has to be built with python USE-flag"
+ die "missing python USE-flag for x11-libs/vte"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ python_version
+ make_desktop_entry pida Pida \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/pida/resources/pixmaps/pida-icon.png \
+ Development
+}
+
+pkg_postinst() {
+ elog "Optional packages pida integrates with:"
+ elog "app-misc/mc (Midnight Commander)"
+ elog "dev-util/gazpacho (Glade-like interface designer)"
+ elog "Revision control: cvs, svn, darcs and many others"
+}