summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-08-04 17:34:30 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-08-04 17:34:30 +0000
commit32e624fb47e9fa71f72cc3fac9b93fe9bc2bd952 (patch)
treebfab0c8916b71ce2941bd0f2f09aa97a486369fa /dev-util/pida
parentAdded dev-util/pida (diff)
downloadgentoo-2-32e624fb47e9fa71f72cc3fac9b93fe9bc2bd952.tar.gz
gentoo-2-32e624fb47e9fa71f72cc3fac9b93fe9bc2bd952.tar.bz2
gentoo-2-32e624fb47e9fa71f72cc3fac9b93fe9bc2bd952.zip
Initial commit. Thank you Björn Michaelsen <bjoern.michaelsen@gmail.com> for the ebuild. bug# 99589
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/ChangeLog10
-rw-r--r--dev-util/pida/Manifest4
-rw-r--r--dev-util/pida/files/digest-pida-0.2.21
-rw-r--r--dev-util/pida/metadata.xml9
-rw-r--r--dev-util/pida/pida-0.2.2.ebuild43
5 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/pida/ChangeLog b/dev-util/pida/ChangeLog
new file mode 100644
index 000000000000..ff4c76f8cb46
--- /dev/null
+++ b/dev-util/pida/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/pida
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.1 2005/08/04 17:34:30 pythonhead Exp $
+
+*pida-0.2.2 (04 Aug 2005)
+
+ 04 Aug 2005; Rob Cakebread <pythonhead@gentoo.org> +pida-0.2.2.ebuild:
+ Initial commit. Thank you Björn Michaelsen <bjoern.michaelsen@gmail.com> for
+ the ebuild. bug# 99589
+
diff --git a/dev-util/pida/Manifest b/dev-util/pida/Manifest
new file mode 100644
index 000000000000..58df465bc045
--- /dev/null
+++ b/dev-util/pida/Manifest
@@ -0,0 +1,4 @@
+MD5 939403a2997e09df8d4aaf71a6399fe4 pida-0.2.2.ebuild 1258
+MD5 eba4b6a021756c705fe89fc73d4f96c2 metadata.xml 258
+MD5 2195a45a0fe63f37763dcfcbbf4283c3 ChangeLog 319
+MD5 22b79c1e6c507a02eaa1c6fc104129a0 files/digest-pida-0.2.2 62
diff --git a/dev-util/pida/files/digest-pida-0.2.2 b/dev-util/pida/files/digest-pida-0.2.2
new file mode 100644
index 000000000000..34b0dcef6a81
--- /dev/null
+++ b/dev-util/pida/files/digest-pida-0.2.2
@@ -0,0 +1 @@
+MD5 a0259f967380ad64b0037d8033466ac2 pida_0.2.2.tar.gz 136632
diff --git a/dev-util/pida/metadata.xml b/dev-util/pida/metadata.xml
new file mode 100644
index 000000000000..98a7e6ee153b
--- /dev/null
+++ b/dev-util/pida/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>pythonhead@gentoo.org</email>
+ <name>Rob Cakebread</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/pida/pida-0.2.2.ebuild b/dev-util/pida/pida-0.2.2.ebuild
new file mode 100644
index 000000000000..d686276cb79e
--- /dev/null
+++ b/dev-util/pida/pida-0.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.2.2.ebuild,v 1.1 2005/08/04 17:34:30 pythonhead Exp $
+
+inherit distutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
+HOMEPAGE="http://pida.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gvim gnome"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ vim? ( >=app-editors/gvim-6.3 )
+ gnome? ( >=x11-libs/gtksourceview-1.2.0
+ >=dev-python/gnome-python-2.10 )
+ >=x11-libs/vte-0.11.11-r2
+ >=dev-python/bicyclerepair-0.9"
+
+pkg_setup() {
+ einfo "The 'gnome' USE flag is only needed if you don't use gvim as the"
+ einfo "embedded editor."
+ if ! use gvim && ! use gnome ; then
+ die "You need to have either gvim or gnome (or both) in your USE flags"
+ fi
+}
+
+pkg_postinst() {
+ if ! built_with_use x11-libs/vte python ; then
+ ewarn "If you want to use the terminal emulator functionality of pida,"
+ ewarn "you will need to recompile x11-libs/vte with USE=\"python\"."
+ einfo "Optional packages pida integrates with:"
+ einfo "app-misc/mc (Midnight Commander)"
+ einfo "dev-util/gazpacho (Glade-like interface designer)"
+ einfo "Revision control: cvs, svn, darcs"
+ fi
+}
+