summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-26 01:38:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-26 01:38:33 +0000
commit936bf8f1abac4c22d5a4b43c2667cc3bc53698a4 (patch)
treefdfe76ee2541b196ad78f74456ef017f6214a0ab /dev-util/perforce
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.tar.gz
gentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.tar.bz2
gentoo-2-936bf8f1abac4c22d5a4b43c2667cc3bc53698a4.zip
add inherit eutils
Diffstat (limited to 'dev-util/perforce')
-rw-r--r--dev-util/perforce/perforce-2002.2-r1.ebuild19
-rw-r--r--dev-util/perforce/perforce-2002.2.ebuild19
-rw-r--r--dev-util/perforce/perforce-2003.1.ebuild16
3 files changed, 31 insertions, 23 deletions
diff --git a/dev-util/perforce/perforce-2002.2-r1.ebuild b/dev-util/perforce/perforce-2002.2-r1.ebuild
index 4452e3f84f3a..ada91437eb16 100644
--- a/dev-util/perforce/perforce-2002.2-r1.ebuild
+++ b/dev-util/perforce/perforce-2002.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.2 2004/01/14 00:27:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2-r1.ebuild,v 1.3 2004/04/26 01:34:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -8,18 +10,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r02.2/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="$BIN_BASE/p4d $BIN_BASE/p4 $BIN_BASE/p4web $BIN_BASE/p4ftpd $BIN_BASE/p4p $DOC_BASE/man/p4.1 $DOC_BASE/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2002.2/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2002.2/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -28,8 +32,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/perforce/perforce-2002.2.ebuild b/dev-util/perforce/perforce-2002.2.ebuild
index c4157d1d5df8..41002763c006 100644
--- a/dev-util/perforce/perforce-2002.2.ebuild
+++ b/dev-util/perforce/perforce-2002.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2.ebuild,v 1.2 2004/01/14 00:27:07 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2002.2.ebuild,v 1.3 2004/04/26 01:36:03 vapier Exp $
+
+inherit eutils
DESCRIPTION="Commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -8,18 +10,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r02.2/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="$BIN_BASE/p4d $BIN_BASE/p4 $BIN_BASE/p4web $BIN_BASE/p4ftpd $BIN_BASE/p4p $DOC_BASE/man/p4.1 $DOC_BASE/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2002.2/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2002.2/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -28,8 +32,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce
diff --git a/dev-util/perforce/perforce-2003.1.ebuild b/dev-util/perforce/perforce-2003.1.ebuild
index 769409723b38..28a4d1a25e6d 100644
--- a/dev-util/perforce/perforce-2003.1.ebuild
+++ b/dev-util/perforce/perforce-2003.1.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce/perforce-2003.1.ebuild,v 1.3 2004/04/26 01:36:27 vapier Exp $
DESCRIPTION="Daemon for a commercial version control system"
HOMEPAGE="http://www.perforce.com/"
@@ -7,18 +8,20 @@ URI_BASE="ftp://ftp.perforce.com/perforce/r03.1/"
BIN_BASE="$URI_BASE/bin.linux24x86"
DOC_BASE="$URI_BASE/doc"
SRC_URI="${BIN_BASE}/p4d ${BIN_BASE}/p4web ${BIN_BASE}/p4ftpd ${DOC_BASE}/man/p4d.1"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2003.1/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-2003.1/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -27,8 +30,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce