summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-26 01:42:17 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-26 01:42:17 +0000
commita1a5db61d3dd5c6689a82882de01462a61242c39 (patch)
tree3af225bcef96e27517777d941c3b85ea02387b66 /dev-util/perforce-gui
parentFix bug 45698 (mozilla-firefox forces downgrade to gtk+-2.2*) (Manifest recom... (diff)
downloadgentoo-2-a1a5db61d3dd5c6689a82882de01462a61242c39.tar.gz
gentoo-2-a1a5db61d3dd5c6689a82882de01462a61242c39.tar.bz2
gentoo-2-a1a5db61d3dd5c6689a82882de01462a61242c39.zip
cleanup the ebuild
Diffstat (limited to 'dev-util/perforce-gui')
-rw-r--r--dev-util/perforce-gui/perforce-gui-2003.1.ebuild11
-rw-r--r--dev-util/perforce-gui/perforce-gui-2003.2.ebuild21
2 files changed, 14 insertions, 18 deletions
diff --git a/dev-util/perforce-gui/perforce-gui-2003.1.ebuild b/dev-util/perforce-gui/perforce-gui-2003.1.ebuild
index 9d78055f804f..8b063806a90d 100644
--- a/dev-util/perforce-gui/perforce-gui-2003.1.ebuild
+++ b/dev-util/perforce-gui/perforce-gui-2003.1.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce-gui/perforce-gui-2003.1.ebuild,v 1.3 2004/04/26 01:40:46 vapier Exp $
inherit rpm
@@ -11,17 +12,17 @@ GUI_NAME="p4v-2003.1-48707.i386"
GUI_RPM="${GUI_NAME}.rpm"
DOC_BASE="$URI_BASE/doc"
SRC_URI="${GUI_BASE}/${GUI_RPM}"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-2003.1/
-src_install()
-{
+src_install() {
cp -R ${WORKDIR}/usr ${D}
}
diff --git a/dev-util/perforce-gui/perforce-gui-2003.2.ebuild b/dev-util/perforce-gui/perforce-gui-2003.2.ebuild
index 4e66d0a0ff32..5864668b0e1f 100644
--- a/dev-util/perforce-gui/perforce-gui-2003.2.ebuild
+++ b/dev-util/perforce-gui/perforce-gui-2003.2.ebuild
@@ -1,31 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce-gui/perforce-gui-2003.2.ebuild,v 1.2 2004/04/26 01:40:46 vapier Exp $
DESCRIPTION="GUI for perforce version control system"
HOMEPAGE="http://www.perforce.com/"
SRC_URI="http://www.perforce.com/downloads/perforce/r03.2/bin.linux24x86/p4v.tgz"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="virtual/glibc"
-#RDEPEND=""
-S=${WORKDIR}
RESTRICT="nomirror nostrip"
-src_unpack ()
-{
- unpack ${A}
-}
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}
-src_compile ()
-{
- # do nothing
- echo > /dev/null
+src_compile() {
+ true
}
-src_install()
-{
+src_install() {
dobin p4v
mkdir -p ${D}/usr/share/doc/p4v-2003.2
cp -R P4VResources/p4vhelp/* ${D}/usr/share/doc/p4v-2003.2/