summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 10:27:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 10:27:21 +0000
commit679bd24d6fbcfff82f9dd4005d2fb7906cadefaf (patch)
tree9a1ac1efd01bb4059433a10b6b3846d4248f81e7 /dev-util/perf
parentDo the handling of not known eapi by depend and not by die. (diff)
downloadgentoo-2-679bd24d6fbcfff82f9dd4005d2fb7906cadefaf.tar.gz
gentoo-2-679bd24d6fbcfff82f9dd4005d2fb7906cadefaf.tar.bz2
gentoo-2-679bd24d6fbcfff82f9dd4005d2fb7906cadefaf.zip
Bump to rc6 (instead of revbumping) so that the RC patch is actually applied. Huge thanks to Zeev Tarantov in bug #302387 for reporting and providing the fix. Also introduce perl USE flag for the Perl scripting in perf, and fix building with USE=perl and --as-needed (patch to be sent upstream).
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/ChangeLog13
-rw-r--r--dev-util/perf/metadata.xml3
-rw-r--r--dev-util/perf/perf-2.6.33_rc5.ebuild131
-rw-r--r--dev-util/perf/perf-2.6.33_rc6.ebuild (renamed from dev-util/perf/perf-2.6.33_rc2.ebuild)18
4 files changed, 26 insertions, 139 deletions
diff --git a/dev-util/perf/ChangeLog b/dev-util/perf/ChangeLog
index db382dfe0a7b..8e370d0c4e51 100644
--- a/dev-util/perf/ChangeLog
+++ b/dev-util/perf/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-util/perf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perf/ChangeLog,v 1.11 2010/01/23 17:22:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perf/ChangeLog,v 1.12 2010/01/31 10:27:21 flameeyes Exp $
+
+*perf-2.6.33_rc6 (31 Jan 2010)
+
+ 31 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -perf-2.6.33_rc2.ebuild, -perf-2.6.33_rc5.ebuild, +perf-2.6.33_rc6.ebuild,
+ metadata.xml:
+ Bump to rc6 (instead of revbumping) so that the RC patch is actually
+ applied. Huge thanks to Zeev Tarantov in bug #302387 for reporting and
+ providing the fix. Also introduce perl USE flag for the Perl scripting in
+ perf, and fix building with USE=perl and --as-needed (patch to be sent
+ upstream).
23 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
perf-2.6.33_rc2.ebuild, perf-2.6.33_rc5.ebuild:
diff --git a/dev-util/perf/metadata.xml b/dev-util/perf/metadata.xml
index 184e9c89c93c..8c848aed843f 100644
--- a/dev-util/perf/metadata.xml
+++ b/dev-util/perf/metadata.xml
@@ -19,5 +19,8 @@
documentation handling tools that are not always welcome on user
systems.
</flag>
+ <flag name="perl">
+ Add support for Perl as a scripting language for perf tools.
+ </flag>
</use>
</pkgmetadata>
diff --git a/dev-util/perf/perf-2.6.33_rc5.ebuild b/dev-util/perf/perf-2.6.33_rc5.ebuild
deleted file mode 100644
index ce2ca5f1ad98..000000000000
--- a/dev-util/perf/perf-2.6.33_rc5.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perf/perf-2.6.33_rc5.ebuild,v 1.2 2010/01/23 17:22:22 flameeyes Exp $
-
-EAPI=2
-
-inherit versionator eutils toolchain-funcs linux-info
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-DESCRIPTION="Userland tools for Linux Performance Counters"
-HOMEPAGE="http://perf.wiki.kernel.org/"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.bz2
- SRC_URI="mirror://kernel/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- mirror://kernel/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.bz2
-SRC_URI="${SRC_URI} mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+demangle +doc"
-
-RDEPEND="demangle? ( sys-devel/binutils )
- dev-libs/elfutils"
-DEPEND="${RDEPEND}
- ${LINUX_PATCH+dev-util/patchutils}
- doc? ( app-text/asciidoc app-text/xmlto )"
-
-S="${WORKDIR}/linux-${LINUX_VER}/tools/perf"
-
-CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
-
-src_unpack() {
- local _tarpattern=
- local _filterdiff=
- for _pattern in {tools/perf,include,lib,"arch/*/include"}; do
- _tarpattern="${_tarpattern} linux-${LINUX_VER}/${_pattern}"
- _filterdiff="${_filterdiff} -i ${_pattern}/*"
- done
-
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
- ebegin "Unpacking partial source tarball"
- tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} ${_tarpattern}
- eend $? || die "tar failed"
-
- ebegin "Filtering partial source patch"
- filterdiff ${_filterdiff} -z "${DISTDIR}"/${LINUX_PATCH} > ${P}.patch || die
- eend $? || die "filterdiff failed"
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- # Drop some upstream too-developer-oriented flags and fix the
- # Makefile in general
- sed -i \
- -e 's:-Werror::' \
- -e 's:-ggdb3::' \
- -e 's:-fstack-protector-all::' \
- -e 's:^LDFLAGS =:EXTLIBS +=:' \
- -e '/-x c - /s:\$(ALL_LDFLAGS):\0 $(EXTLIBS):' \
- -e '/^ALL_CFLAGS =/s:$: $(CFLAGS_OPTIMIZE):' \
- -e '/^ALL_LDFLAGS =/s:$: $(LDFLAGS_OPTIMIZE):' \
- "${S}"/Makefile
-
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${WORKDIR}"/${P}.patch
- fi
-}
-
-src_compile() {
- local makeargs=
-
- use demangle || makeargs="${makeargs} NO_DEMANGLE= "
-
- emake ${makeargs} \
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- prefix="/usr" bindir_relative="sbin" \
- CFLAGS_OPTIMIZE="${CFLAGS}" \
- LDFLAGS_OPTIMIZE="${LDFLAGS}" || die
-
- if use doc; then
- pushd Documentation
- emake ${makeargs} || die
- popd
- fi
-}
-
-src_test() {
- :
-}
-
-src_install() {
- # Don't use make install or it'll be re-building the stuff :(
- dobin perf || die
-
- dodoc CREDITS || die
-
- if use doc; then
- dodoc Documentation/*.txt || die
- dohtml Documentation/*.html || die
- doman Documentation/*.1 || die
- fi
-}
-
-pkg_postinst() {
- if ! use doc; then
- elog "Without the doc USE flag you won't get any documentation nor man pages."
- elog "And without man pages, you won't get any --help output for perf and its"
- elog "sub-tools."
- fi
-}
diff --git a/dev-util/perf/perf-2.6.33_rc2.ebuild b/dev-util/perf/perf-2.6.33_rc6.ebuild
index 21ae75d0610a..be686e7162e7 100644
--- a/dev-util/perf/perf-2.6.33_rc2.ebuild
+++ b/dev-util/perf/perf-2.6.33_rc6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/perf/perf-2.6.33_rc2.ebuild,v 1.2 2010/01/23 17:22:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perf/perf-2.6.33_rc6.ebuild,v 1.1 2010/01/31 10:27:21 flameeyes Exp $
EAPI=2
@@ -30,9 +30,10 @@ SRC_URI="${SRC_URI} mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+demangle +doc"
+IUSE="+demangle +doc perl"
RDEPEND="demangle? ( sys-devel/binutils )
+ perl? ( || ( >=dev-lang/perl-5.10 sys-devel/libperl ) )
dev-libs/elfutils"
DEPEND="${RDEPEND}
${LINUX_PATCH+dev-util/patchutils}
@@ -57,7 +58,7 @@ src_unpack() {
eend $? || die "tar failed"
ebegin "Filtering partial source patch"
- filterdiff ${_filterdiff} -z "${DISTDIR}"/${LINUX_PATCH} > ${P}.patch || die
+ filterdiff -p1 ${_filterdiff} -z "${DISTDIR}"/${LINUX_PATCH} > ${P}.patch || die
eend $? || die "filterdiff failed"
MY_A=
@@ -70,6 +71,11 @@ src_unpack() {
}
src_prepare() {
+ if [[ -n ${LINUX_PATCH} ]]; then
+ cd "${WORKDIR}"/linux-"${LINUX_VER}"
+ epatch "${WORKDIR}"/${P}.patch
+ fi
+
# Drop some upstream too-developer-oriented flags and fix the
# Makefile in general
sed -i \
@@ -77,20 +83,18 @@ src_prepare() {
-e 's:-ggdb3::' \
-e 's:-fstack-protector-all::' \
-e 's:^LDFLAGS =:EXTLIBS +=:' \
+ -e '/PERL_EMBED_LDOPTS/s:ALL_LDFLAGS +=:EXTLIBS +=:' \
-e '/-x c - /s:\$(ALL_LDFLAGS):\0 $(EXTLIBS):' \
-e '/^ALL_CFLAGS =/s:$: $(CFLAGS_OPTIMIZE):' \
-e '/^ALL_LDFLAGS =/s:$: $(LDFLAGS_OPTIMIZE):' \
"${S}"/Makefile
-
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${WORKDIR}"/${P}.patch
- fi
}
src_compile() {
local makeargs=
use demangle || makeargs="${makeargs} NO_DEMANGLE= "
+ use perl || makeargs="${makeargs} NO_LIBPERL= "
emake ${makeargs} \
CC="$(tc-getCC)" AR="$(tc-getAR)" \