summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-07-23 19:48:18 +0000
committerMichael Januszewski <spock@gentoo.org>2008-07-23 19:48:18 +0000
commit9221b42d1897874e3e1e544d2549d6adf8f5331a (patch)
tree806a89aec94c30787d54740a453a16a1c4ed428d /dev-util/oprofile
parentVersion bump, mostly bugfixes after the release candidates (diff)
downloadgentoo-2-9221b42d1897874e3e1e544d2549d6adf8f5331a.tar.gz
gentoo-2-9221b42d1897874e3e1e544d2549d6adf8f5331a.tar.bz2
gentoo-2-9221b42d1897874e3e1e544d2549d6adf8f5331a.zip
Remove old ebuilds.
(Portage version: 2.2_rc2/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog10
-rw-r--r--dev-util/oprofile/files/oprofile-0.8.2.patch12
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.1-gcc41-compilation-fix.diff93
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.1-opcontrol_path.diff18
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.2-amd64.patch86
-rw-r--r--dev-util/oprofile/oprofile-0.9.1-r1.ebuild82
-rw-r--r--dev-util/oprofile/oprofile-0.9.2.ebuild79
7 files changed, 9 insertions, 371 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index eba4a7e638b0..3a1a37f0be88 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.49 2008/07/23 19:44:43 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.50 2008/07/23 19:48:17 spock Exp $
+
+ 23 Jul 2008; Michał Januszewski <spock@gentoo.org>
+ -files/oprofile-0.8.2.patch,
+ -files/oprofile-0.9.1-gcc41-compilation-fix.diff,
+ -files/oprofile-0.9.1-opcontrol_path.diff,
+ -files/oprofile-0.9.2-amd64.patch, -oprofile-0.9.1-r1.ebuild,
+ -oprofile-0.9.2.ebuild:
+ Remove old ebuilds.
*oprofile-0.9.4 (23 Jul 2008)
diff --git a/dev-util/oprofile/files/oprofile-0.8.2.patch b/dev-util/oprofile/files/oprofile-0.8.2.patch
deleted file mode 100644
index e5284b7108a5..000000000000
--- a/dev-util/oprofile/files/oprofile-0.8.2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur oprofile-0.8.2/module/oprofile.h oprofile-0.8.2-fixed/module/oprofile.h
---- oprofile-0.8.2/module/oprofile.h 2003-11-01 19:56:53.000000000 +0100
-+++ oprofile-0.8.2-fixed/module/oprofile.h 2005-04-26 20:10:16.000000000 +0200
-@@ -141,7 +141,7 @@
- * performance counter */
- extern struct op_int_operations op_rtc_ops;
-
--void FASTCALL(op_do_profile(uint cpu, long eip, long irq_enabled, int ctr));
-+void op_do_profile(uint cpu, long eip, long irq_enabled, int ctr);
- extern struct _oprof_data oprof_data[NR_CPUS];
- extern struct oprof_sysctl sysctl_parms;
- extern int lproc_dointvec(ctl_table *table, int write, struct file *filp, void *buffer, size_t *lenp);
diff --git a/dev-util/oprofile/files/oprofile-0.9.1-gcc41-compilation-fix.diff b/dev-util/oprofile/files/oprofile-0.9.1-gcc41-compilation-fix.diff
deleted file mode 100644
index 82938acd351e..000000000000
--- a/dev-util/oprofile/files/oprofile-0.9.1-gcc41-compilation-fix.diff
+++ /dev/null
@@ -1,93 +0,0 @@
---- libpp/arrange_profiles.cpp.orig 2006-02-15 13:26:05.780995781 +0100
-+++ libpp/arrange_profiles.cpp 2006-02-15 13:16:37.997633075 +0100
-@@ -24,6 +24,44 @@
- #include "parse_filename.h"
- #include "locate_images.h"
-
-+bool profile_classes::matches(profile_classes const & classes)
-+{
-+ if (v.size() != classes.v.size())
-+ return false;
-+
-+ axis_types const axis2 = classes.axis;
-+
-+ switch (axis) {
-+ case AXIS_EVENT:
-+ break;
-+ case AXIS_TGID:
-+ case AXIS_TID:
-+ return axis2 == AXIS_TID || axis2 == AXIS_TGID;
-+ case AXIS_CPU:
-+ return axis2 == AXIS_CPU;
-+ case AXIS_MAX:
-+ return false;
-+ }
-+
-+ // check that the events match (same event, count)
-+
-+ std::vector<profile_class>::const_iterator it1 = v.begin();
-+ std::vector<profile_class>::const_iterator end1 = v.end();
-+ std::vector<profile_class>::const_iterator it2 = classes.v.begin();
-+
-+ while (it1 != end1) {
-+ if (it1->ptemplate.event != it2->ptemplate.event)
-+ return false;
-+ if (it1->ptemplate.count != it2->ptemplate.count)
-+ return false;
-+ // differing unit mask is considered comparable
-+ ++it1;
-+ ++it2;
-+ }
-+
-+ return true;
-+}
-+
- using namespace std;
-
- namespace {
-@@ -90,45 +128,6 @@
- };
-
-
--bool profile_classes::matches(profile_classes const & classes)
--{
-- if (v.size() != classes.v.size())
-- return false;
--
-- axis_types const axis2 = classes.axis;
--
-- switch (axis) {
-- case AXIS_EVENT:
-- break;
-- case AXIS_TGID:
-- case AXIS_TID:
-- return axis2 == AXIS_TID || axis2 == AXIS_TGID;
-- case AXIS_CPU:
-- return axis2 == AXIS_CPU;
-- case AXIS_MAX:
-- return false;
-- }
--
-- // check that the events match (same event, count)
--
-- vector<profile_class>::const_iterator it1 = v.begin();
-- vector<profile_class>::const_iterator end1 = v.end();
-- vector<profile_class>::const_iterator it2 = classes.v.begin();
--
-- while (it1 != end1) {
-- if (it1->ptemplate.event != it2->ptemplate.event)
-- return false;
-- if (it1->ptemplate.count != it2->ptemplate.count)
-- return false;
-- // differing unit mask is considered comparable
-- ++it1;
-- ++it2;
-- }
--
-- return true;
--}
--
--
- /// We have more than one axis of classification, tell the user.
- void report_error(profile_classes const & classes, axis_types newaxis)
- {
diff --git a/dev-util/oprofile/files/oprofile-0.9.1-opcontrol_path.diff b/dev-util/oprofile/files/oprofile-0.9.1-opcontrol_path.diff
deleted file mode 100644
index 2d2dabdbf16c..000000000000
--- a/dev-util/oprofile/files/oprofile-0.9.1-opcontrol_path.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Naurp oprofile-0.9.1-orig/utils/opcontrol oprofile-0.9.1/utils/opcontrol
---- oprofile-0.9.1-orig/utils/opcontrol 2006-02-12 15:26:15.000000000 +0100
-+++ oprofile-0.9.1/utils/opcontrol 2006-02-12 15:26:45.000000000 +0100
-@@ -1409,12 +1409,12 @@ check_version()
-
- # main
-
-+PATH=/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin
-+
- # determine the location of opcontrol and related programs
- OPCONTROL=`which $0`
- OPDIR=`dirname $OPCONTROL`
-
--PATH=/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin
--
- check_version_help $@
-
- if test -z "$1"; then
diff --git a/dev-util/oprofile/files/oprofile-0.9.2-amd64.patch b/dev-util/oprofile/files/oprofile-0.9.2-amd64.patch
deleted file mode 100644
index 06c5e9a7728f..000000000000
--- a/dev-util/oprofile/files/oprofile-0.9.2-amd64.patch
+++ /dev/null
@@ -1,86 +0,0 @@
---- a/libop/op_alloc_counter.c 2007-03-21 02:31:40.000000000 +0000
-+++ b/libop/op_alloc_counter.c 2007-03-21 02:31:42.000000000 +0000
-@@ -12,6 +12,8 @@
- */
-
- #include <stdlib.h>
-+#include <ctype.h>
-+#include <dirent.h>
-
- #include "op_events.h"
- #include "op_libiberty.h"
-@@ -130,7 +132,7 @@
- counter_arc const * arc = list_entry(pos, counter_arc, next);
-
- if (allocated_mask & (1 << arc->counter))
-- return 0;
-+ continue;
-
- counter_map[depth] = arc->counter;
-
-@@ -143,6 +145,42 @@
- return 0;
- }
-
-+/* determine which directories are counter directories
-+ */
-+static int perfcounterdir(const struct dirent * entry)
-+{
-+ return (isdigit(entry->d_name[0]));
-+}
-+
-+/**
-+ * @param mask pointer where to place bit mask of unavailable counters
-+ *
-+ * return >= 0 number of counters that are available
-+ * < 0 could not determine number of counters
-+ *
-+ */
-+static int op_get_counter_mask(u32 * mask)
-+{
-+ struct dirent **counterlist;
-+ int count, i;
-+ /* assume nothing is available */
-+ u32 available=0;
-+
-+ count = scandir("/dev/oprofile", &counterlist, perfcounterdir,
-+ alphasort);
-+ if (count < 0)
-+ /* unable to determine bit mask */
-+ return -1;
-+ /* convert to bit map (0 where counter exists) */
-+ for (i=0; i<count; ++i) {
-+ available |= 1 << atoi(counterlist[i]->d_name);
-+ free(counterlist[i]);
-+ }
-+ *mask=~available;
-+ free(counterlist);
-+ return count;
-+}
-+
-
- size_t * map_event_to_counter(struct op_event const * pev[], int nr_events,
- op_cpu cpu_type)
-@@ -150,8 +188,11 @@
- counter_arc_head * ctr_arc;
- size_t * counter_map;
- int nr_counters;
-+ u32 unavailable_counters = 0;
-
-- nr_counters = op_get_nr_counters(cpu_type);
-+ nr_counters = op_get_counter_mask(&unavailable_counters);
-+ if (nr_counters < 0)
-+ nr_counters = op_get_nr_counters(cpu_type);
- if (nr_counters < nr_events)
- return 0;
-
-@@ -159,7 +200,8 @@
-
- counter_map = xmalloc(nr_counters * sizeof(size_t));
-
-- if (!allocate_counter(ctr_arc, nr_events, 0, 0, counter_map)) {
-+ if (!allocate_counter(ctr_arc, nr_events, 0, unavailable_counters,
-+ counter_map)) {
- free(counter_map);
- counter_map = 0;
- }
diff --git a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild b/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
deleted file mode 100644
index 8dceb820f407..000000000000
--- a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1-r1.ebuild,v 1.12 2007/04/16 15:15:00 spock Exp $
-
-inherit eutils qt3 linux-info
-
-DESCRIPTION="A transparent low-overhead system-wide profiler"
-HOMEPAGE="http://oprofile.sourceforge.net"
-SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz
- mirror://gentoo/${P}-g4-counters.patch.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-# IUSE: it also needs kernel sources but all gentoo users have them
-IUSE="qt3"
-DEPEND=">=dev-libs/popt-1.7-r1
- >=sys-devel/binutils-2.14.90.0.6-r3
- >=sys-libs/glibc-2.3.2-r1
- qt3? ( $(qt_min_version 3.3) )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/oprofile-0.9.1-opcontrol_path.diff
- epatch ${FILESDIR}/oprofile-0.9.1-gcc41-compilation-fix.diff
- epatch ${WORKDIR}/${P}-g4-counters.patch
-}
-
-src_compile() {
- local myconf=""
-
- if use qt3
- then
- REALHOME="$HOME"
- mkdir -p $T/fakehome/.kde
- mkdir -p $T/fakehome/.qt
- export HOME="$T/fakehome"
- addwrite "${QTDIR}/etc/settings"
-
- # things that should access the real homedir
- [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
- else
- myconf="${myconf} --with-qt-dir=/void"
- fi
-
- myconf="${myconf} --with-x"
-
- case ${KV_FULL} in
- 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
- 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
- *) die "Kernel version '${KV_FULL}' not supported";;
- esac
- econf ${myconf} || die "econf failed"
-
- local mymake=""
-
- sed -i -e "s,depmod -a,:,g" Makefile
- emake ${mymake} || die "emake failed"
-}
-
-src_install() {
- local myinst=""
-
- myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
- make DESTDIR=${D} ${myinst} install || die "make install failed"
-
- dodoc ChangeLog* README TODO
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == / ]] ; then
- [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
- fi
-
- echo
- elog "Now load the oprofile module by running:"
- elog " # opcontrol --init"
- elog "Then read manpages and this html doc:"
- elog " /usr/share/doc/oprofile/oprofile.html"
- echo
-}
diff --git a/dev-util/oprofile/oprofile-0.9.2.ebuild b/dev-util/oprofile/oprofile-0.9.2.ebuild
deleted file mode 100644
index 05bc4cad6a6c..000000000000
--- a/dev-util/oprofile/oprofile-0.9.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.2.ebuild,v 1.6 2007/04/16 15:15:00 spock Exp $
-
-inherit eutils qt3 linux-info
-
-DESCRIPTION="A transparent low-overhead system-wide profiler"
-HOMEPAGE="http://oprofile.sourceforge.net"
-SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-# IUSE: it also needs kernel sources but all gentoo users have them
-IUSE="qt3"
-DEPEND=">=dev-libs/popt-1.7-r1
- >=sys-devel/binutils-2.14.90.0.6-r3
- >=sys-libs/glibc-2.3.2-r1
- qt3? ( $(qt_min_version 3.3) )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/oprofile-0.9.2-amd64.patch
-}
-
-src_compile() {
- local myconf=""
-
- if use qt3
- then
- REALHOME="$HOME"
- mkdir -p $T/fakehome/.kde
- mkdir -p $T/fakehome/.qt
- export HOME="$T/fakehome"
- addwrite "${QTDIR}/etc/settings"
-
- # things that should access the real homedir
- [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
- else
- myconf="${myconf} --with-qt-dir=/void"
- fi
-
- myconf="${myconf} --with-x"
-
- case ${KV_FULL} in
- 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
- 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
- *) die "Kernel version '${KV_FULL}' not supported";;
- esac
- econf ${myconf} || die "econf failed"
-
- local mymake=""
-
- sed -i -e "s,depmod -a,:,g" Makefile
- emake ${mymake} || die "emake failed"
-}
-
-src_install() {
- local myinst=""
-
- myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
- make DESTDIR=${D} ${myinst} install || die "make install failed"
-
- dodoc ChangeLog* README TODO
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == / ]] ; then
- [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
- fi
-
- echo
- elog "Now load the oprofile module by running:"
- elog " # opcontrol --init"
- elog "Then read manpages and this html doc:"
- elog " /usr/share/doc/oprofile/oprofile.html"
- echo
-}