summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-22 14:57:18 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-22 14:57:18 +0000
commit87dfb913fec37e90f27d3eee6e9b727100269e4c (patch)
treec5c5f4ed297cc02cf5fabd021008cae0a1ca0eef /dev-util/oprofile
parentAdded alternative for lang=de, bug #297400 thank Ulrich Müller for report. (diff)
downloadgentoo-2-87dfb913fec37e90f27d3eee6e9b727100269e4c.tar.gz
gentoo-2-87dfb913fec37e90f27d3eee6e9b727100269e4c.tar.bz2
gentoo-2-87dfb913fec37e90f27d3eee6e9b727100269e4c.zip
Version bump, bug #297609.
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog7
-rw-r--r--dev-util/oprofile/oprofile-0.9.6.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 7f9cdda75c15..2a91fb0e350c 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.59 2009/08/02 22:57:48 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.60 2009/12/22 14:57:18 pva Exp $
+
+*oprofile-0.9.6 (22 Dec 2009)
+
+ 22 Dec 2009; Peter Volkov <pva@gentoo.org> +oprofile-0.9.6.ebuild:
+ Version bump, bug #297609.
*oprofile-0.9.5 (02 Aug 2009)
diff --git a/dev-util/oprofile/oprofile-0.9.6.ebuild b/dev-util/oprofile/oprofile-0.9.6.ebuild
new file mode 100644
index 000000000000..7aac84d197fe
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.6.ebuild,v 1.1 2009/12/22 14:57:18 pva Exp $
+
+EAPI=1
+
+inherit qt3 linux-info
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="qt3"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt3? ( x11-libs/qt:3 )"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present OPROFILE; then
+ elog "In order for oprofile to work, you need to configure your kernel"
+ elog "with CONFIG_OPROFILE set to 'm' or 'y'."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+
+ if use qt3
+ then
+ REALHOME="$HOME"
+ mkdir -p "$T"/fakehome/.kde
+ mkdir -p "$T"/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case ${KV_FULL} in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '${KV_FULL}' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
+ make DESTDIR="${D}" ${myinst} htmldir="/usr/share/doc/${PF}" install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == / ]] ; then
+ [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
+ fi
+
+ echo
+ elog "Now load the oprofile module by running:"
+ elog " # opcontrol --init"
+ elog "Then read manpages and this html doc:"
+ elog " /usr/share/doc/${PF}/oprofile.html"
+ echo
+}