summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-07-05 18:49:42 +0000
committerMichael Januszewski <spock@gentoo.org>2009-07-05 18:49:42 +0000
commit92f26f6d28ba9e343d2ad7c4d11e118a5d4bc82d (patch)
tree1298f3917d1f5b7891ce39e6050aaa8d2b5946b2 /dev-util/nvidia-cuda-toolkit
parentfix #273167 (diff)
downloadgentoo-2-92f26f6d28ba9e343d2ad7c4d11e118a5d4bc82d.tar.gz
gentoo-2-92f26f6d28ba9e343d2ad7c4d11e118a5d4bc82d.tar.bz2
gentoo-2-92f26f6d28ba9e343d2ad7c4d11e118a5d4bc82d.zip
Add support for the CUDA debugger (bug #274100).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/nvidia-cuda-toolkit')
-rw-r--r--dev-util/nvidia-cuda-toolkit/ChangeLog8
-rw-r--r--dev-util/nvidia-cuda-toolkit/metadata.xml3
-rw-r--r--dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-2.2-r2.ebuild132
3 files changed, 142 insertions, 1 deletions
diff --git a/dev-util/nvidia-cuda-toolkit/ChangeLog b/dev-util/nvidia-cuda-toolkit/ChangeLog
index 6c0602360743..e259a2a61678 100644
--- a/dev-util/nvidia-cuda-toolkit/ChangeLog
+++ b/dev-util/nvidia-cuda-toolkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/nvidia-cuda-toolkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-toolkit/ChangeLog,v 1.7 2009/07/05 07:00:11 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-toolkit/ChangeLog,v 1.8 2009/07/05 18:49:42 spock Exp $
+
+*nvidia-cuda-toolkit-2.2-r2 (05 Jul 2009)
+
+ 05 Jul 2009; Michał Januszewski <spock@gentoo.org>
+ +nvidia-cuda-toolkit-2.2-r2.ebuild, metadata.xml:
+ Add support for the CUDA debugger (bug #274100).
05 Jul 2009; Michał Januszewski <spock@gentoo.org>
nvidia-cuda-toolkit-2.2-r1.ebuild:
diff --git a/dev-util/nvidia-cuda-toolkit/metadata.xml b/dev-util/nvidia-cuda-toolkit/metadata.xml
index 54cc6b7049e4..25ec5c4b9e59 100644
--- a/dev-util/nvidia-cuda-toolkit/metadata.xml
+++ b/dev-util/nvidia-cuda-toolkit/metadata.xml
@@ -10,6 +10,9 @@
<flag name='profiler'>
Installs the NVIDIA CUDA visual profiler.
</flag>
+ <flag name='debugger'>
+ Installs the CUDA debugger.
+ </flag>
</use>
</pkgmetadata>
diff --git a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-2.2-r2.ebuild b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-2.2-r2.ebuild
new file mode 100644
index 000000000000..d4e679b7b3a2
--- /dev/null
+++ b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-2.2-r2.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-2.2-r2.ebuild,v 1.1 2009/07/05 18:49:42 spock Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="NVIDIA CUDA Toolkit"
+HOMEPAGE="http://developer.nvidia.com/cuda"
+
+CUDA_V=${PV//./_}
+
+BASE_URI="http://developer.download.nvidia.com/compute/cuda/${CUDA_V}/toolkit"
+SRC_URI="amd64? ( ${BASE_URI}/cudatoolkit_${PV}_linux_64_suse11.1.run
+ debugger? ( ${BASE_URI}/cudagdb_2.2_linux_64_rhel5.3.run ) )
+ x86? ( ${BASE_URI}/cudatoolkit_${PV}_linux_32_suse11.1.run
+ debugger? ( ${BASE_URI}/cudagdb_2.2_linux_32_rhel5.3.run ) )"
+
+LICENSE="NVIDIA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debugger doc profiler"
+
+DEPEND="!dev-util/nvidia-cuda-profiler"
+RDEPEND="${DEPEND}
+ profiler? ( x86? (
+ x11-libs/qt-gui
+ x11-libs/qt-core
+ x11-libs/qt-assistant
+ x11-libs/qt-sql[sqlite] )
+ )
+ debugger? ( >=sys-libs/libtermcap-compat-2.0.8-r2 )"
+RESTRICT="strip binchecks"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ for f in ${A} ; do
+ unpack_makeself ${f}
+ done
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-enum_fix.patch"
+}
+
+src_install() {
+ local DEST=/opt/cuda
+ export CONF_LIBDIR_OVERRIDE="lib"
+
+ # HACK: temporary workaround until CONF_LIBDIR_OVERRIDE is respected.
+ export LIBDIR_amd64="lib"
+
+ into ${DEST}
+ dobin bin/*
+ dolib lib/*
+
+ chmod a-x "${D}/${DEST}/bin/nvcc.profile"
+
+ # doman does not respect DESTTREE
+ insinto ${DEST}/man/man1
+ doins man/man1/*
+ insinto ${DEST}/man/man3
+ doins man/man3/*
+ prepman ${DEST}
+
+ insinto ${DEST}/include
+ doins include/*.h
+ insinto ${DEST}/include/crt
+ doins include/crt/*.h
+
+ insinto ${DEST}/src
+ doins src/*
+
+ into ${DEST}/open64
+ dobin open64/bin/*
+ libopts -m0755
+ dolib open64/lib/*
+
+ if use doc ; then
+ insinto ${DEST}/doc
+ doins -r doc/*
+ fi
+
+ cat > "${T}/env" << EOF
+PATH=${DEST}/bin
+ROOTPATH=${DEST}/bin
+LDPATH=${DEST}/lib
+MANPATH=${DEST}/man
+EOF
+ newenvd "${T}/env" 99cuda
+
+ if use profiler; then
+ into ${DEST}/cudaprof
+ dobin cudaprof/bin/cudaprof
+
+ cat > "${T}/env" << EOF
+PATH=${DEST}/cudaprof/bin
+ROOTPATH=${DEST}/cudaprof/bin
+EOF
+ if use x86 ; then
+ dosym /usr/bin/assistant ${DEST}/cudaprof/bin
+ else
+ dobin cudaprof/bin/assistant
+ insinto ${DEST}/cudaprof/bin
+ doins cudaprof/bin/*.so*
+ insinto ${DEST}/cudaprof/bin/sqldrivers
+ doins cudaprof/bin/sqldrivers/*
+
+ cat >> "${T}/env" << EOF
+LDPATH=${DEST}/cudaprof/bin
+EOF
+ fi
+
+ newenvd "${T}/env" 99cudaprof
+
+ if use doc; then
+ insinto ${DEST}/cudaprof/doc
+ doins cudaprof/doc/*
+ insinto ${DEST}/cudaprof/projects
+ doins cudaprof/projects/*
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "If you want to natively run the code generated by CUDA, you will need"
+ elog ">=x11-drivers/nvidia-drivers-185.18.08."
+ elog ""
+ elog "Run '. /etc/profile' before using the CUDA toolkit. "
+}