summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-03-11 10:22:32 +0000
committerAlin Năstac <mrness@gentoo.org>2007-03-11 10:22:32 +0000
commit387deeb51ef52ba22d77d8ab6d0a87ea64ad30d5 (patch)
treefcd25de6bb0f2a7b59dc8159734f40628af7cd08 /dev-util/nsis
parentPorting to Modular X. (diff)
downloadgentoo-2-387deeb51ef52ba22d77d8ab6d0a87ea64ad30d5.tar.gz
gentoo-2-387deeb51ef52ba22d77d8ab6d0a87ea64ad30d5.tar.bz2
gentoo-2-387deeb51ef52ba22d77d8ab6d0a87ea64ad30d5.zip
always strip Windows binaries; no point in having debug info in them
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util/nsis')
-rw-r--r--dev-util/nsis/nsis-2.24.ebuild40
1 files changed, 19 insertions, 21 deletions
diff --git a/dev-util/nsis/nsis-2.24.ebuild b/dev-util/nsis/nsis-2.24.ebuild
index e1cedd9ef14c..f2717ecfc083 100644
--- a/dev-util/nsis/nsis-2.24.ebuild
+++ b/dev-util/nsis/nsis-2.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.24.ebuild,v 1.1 2007/03/11 09:59:23 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.24.ebuild,v 1.2 2007/03/11 10:22:32 mrness Exp $
inherit eutils
@@ -34,31 +34,29 @@ src_unpack() {
src_compile() {
scons PREFIX=/usr PREFIX_CONF=/etc PREFIX_DOC="/usr/share/doc/${P}" PREFIX_DEST="${D}" \
- SKIPPLUGINS=System VERSION=${PV} STRIP=no || die "scons failed"
+ SKIPPLUGINS=System VERSION=${PV} DEBUG=no STRIP=no || die "scons failed"
}
src_install() {
scons PREFIX=/usr PREFIX_CONF=/etc PREFIX_DOC="/usr/share/doc/${P}" PREFIX_DEST="${D}" \
- SKIPPLUGINS=System VERSION=${PV} STRIP=no install || die "scons install failed"
+ SKIPPLUGINS=System VERSION=${PV} DEBUG=no STRIP=no install || die "scons install failed"
fperms -R go-w,a-x,a+X /usr/share/${PN}/ /usr/share/doc/${P}/ /etc/nsisconf.nsh
- # Strip Windows binaries
- if ! hasq nostrip ${FEATURES} ; then
- local STRIP_FLAGS=${PORTAGE_STRIP_FLAGS:---strip-unneeded}
- echo
- echo "strip: mingw32-strip $STRIP_FLAGS"
-
- cd "${D}"
- local FILE
- for FILE in $(find -iregex '.*\.\(dll\|exe\)$' | sed 's:^\./::') ; do
- if [[ "${FILE##*\/}" = "NSIS.exe" ]]; then
- # This program is distributed binary with nothing strippable in it
- # Avoid "File in wrong format" error
- continue
- fi
- echo " ${FILE}"
- mingw32-strip ${STRIP_FLAGS} "${FILE}"
- done
- fi
+ # Always strip Windows binaries; no point in having Windows debug info
+ local STRIP_FLAGS="--strip-unneeded"
+ echo
+ echo "strip: mingw32-strip ${STRIP_FLAGS}"
+
+ cd "${D}"
+ local FILE
+ for FILE in $(find -iregex '.*\.\(dll\|exe\)$' | sed 's:^\./::') ; do
+ if [[ "${FILE##*\/}" = "NSIS.exe" ]]; then
+ # This program is distributed binary with nothing strippable in it
+ # Avoid "File in wrong format" error
+ continue
+ fi
+ echo " ${FILE}"
+ mingw32-strip ${STRIP_FLAGS} "${FILE}"
+ done
}