summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-31 18:45:04 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-31 18:45:04 +0000
commitdbc9dd3093fdca66f59dcd996cb65cc9953cb019 (patch)
tree3657d56cc83fe5ed318f3610afc69db84cba6192 /dev-util/ninja
parentinitial add of python-novaclient (diff)
downloadgentoo-2-dbc9dd3093fdca66f59dcd996cb65cc9953cb019.tar.gz
gentoo-2-dbc9dd3093fdca66f59dcd996cb65cc9953cb019.tar.bz2
gentoo-2-dbc9dd3093fdca66f59dcd996cb65cc9953cb019.zip
version bump
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-util/ninja')
-rw-r--r--dev-util/ninja/ChangeLog7
-rw-r--r--dev-util/ninja/ninja-1.1.0.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-util/ninja/ChangeLog b/dev-util/ninja/ChangeLog
index 18ffa2bd187c..4155f96914ed 100644
--- a/dev-util/ninja/ChangeLog
+++ b/dev-util/ninja/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ninja
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.5 2012/12/30 23:53:50 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.6 2012/12/31 18:45:04 ottxor Exp $
+
+*ninja-1.1.0 (31 Dec 2012)
+
+ 31 Dec 2012; Christoph Junghans <ottxor@gentoo.org> +ninja-1.1.0.ebuild:
+ version bump
30 Dec 2012; Christoph Junghans <ottxor@gentoo.org> ninja-1.0.0.ebuild:
fix collision with net-irc/ninja (bug #436804)
diff --git a/dev-util/ninja/ninja-1.1.0.ebuild b/dev-util/ninja/ninja-1.1.0.ebuild
new file mode 100644
index 000000000000..f303bd47c2e9
--- /dev/null
+++ b/dev-util/ninja/ninja-1.1.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-1.1.0.ebuild,v 1.1 2012/12/31 18:45:04 ottxor Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit bash-completion-r1 elisp-common python toolchain-funcs
+
+if [ "${PV}" = "999999" ]; then
+ EGIT_REPO_URI="git://github.com/martine/ninja.git http://github.com/martine/ninja.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/martine/ninja/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A small build system similar to make."
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs vim-syntax zsh-completion"
+
+DEPEND="
+ dev-util/re2c
+ doc? ( app-text/asciidoc app-doc/doxygen )
+ "
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ tc-export BUILD_CXX
+ ./bootstrap.py || die
+ if use doc; then
+ ./ninja doxygen || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ use doc && dohtml -r doc/doxygen/html/*
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}