summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-10 20:25:44 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-10 20:25:44 +0000
commite2bd88be29703b8a21c3062a2d7765dd65393596 (patch)
tree3d3aeed20e1ffc3d4bb47985e549316061eeae26 /dev-util/motor
parentVersion bump. (diff)
downloadgentoo-2-e2bd88be29703b8a21c3062a2d7765dd65393596.tar.gz
gentoo-2-e2bd88be29703b8a21c3062a2d7765dd65393596.tar.bz2
gentoo-2-e2bd88be29703b8a21c3062a2d7765dd65393596.zip
new ebuild for text based IDE
Diffstat (limited to 'dev-util/motor')
-rw-r--r--dev-util/motor/ChangeLog9
-rw-r--r--dev-util/motor/files/digest-motor-3.2.41
-rw-r--r--dev-util/motor/motor-3.2.4.ebuild39
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/motor/ChangeLog b/dev-util/motor/ChangeLog
new file mode 100644
index 000000000000..9759fda87b02
--- /dev/null
+++ b/dev-util/motor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-util/motor
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/motor/ChangeLog,v 1.1 2003/04/10 20:25:44 liquidx Exp $
+
+*motor-3.2.4 (10 Apr 2003)
+
+ 10 Apr 2003; Alastair Tse <liquidx@gentoo.org> motor-3.2.4.ebuild:
+ new ebuild. submitted by Max Mylokostenko <max_m@ukrpost.net>.
+
diff --git a/dev-util/motor/files/digest-motor-3.2.4 b/dev-util/motor/files/digest-motor-3.2.4
new file mode 100644
index 000000000000..7789b5cd7bac
--- /dev/null
+++ b/dev-util/motor/files/digest-motor-3.2.4
@@ -0,0 +1 @@
+MD5 523902f2cce0d36e93c17d593a410f86 motor-3.2.4.tar.bz2 399968
diff --git a/dev-util/motor/motor-3.2.4.ebuild b/dev-util/motor/motor-3.2.4.ebuild
new file mode 100644
index 000000000000..48db54f359eb
--- /dev/null
+++ b/dev-util/motor/motor-3.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/motor/motor-3.2.4.ebuild,v 1.1 2003/04/10 20:25:44 liquidx Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Motor is a text mode based programming environment for Linux"
+HOMEPAGE="http://konst.org.ua/motor/"
+SRC_URI="http://konst.org.ua/download/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix="/usr" \
+ --infodir="/usr/share/info" \
+ --mandir="/usr/share/man" \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING README TODO FAQ ChangeLog
+ docinto tutorial
+ dohtml -r tutorial/*
+
+}