summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-21 23:51:52 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-21 23:51:52 +0000
commit3d8e894530ba15d05e691fa1e71dd67f80dbdce0 (patch)
tree8069e2e8700030006cb3bfe42a9ea34214bc8f1c /dev-util/monodoc
parent(#167281) Bump to latest. The doxygen dep is mandatory. (diff)
downloadgentoo-2-3d8e894530ba15d05e691fa1e71dd67f80dbdce0.tar.gz
gentoo-2-3d8e894530ba15d05e691fa1e71dd67f80dbdce0.tar.bz2
gentoo-2-3d8e894530ba15d05e691fa1e71dd67f80dbdce0.zip
dev-util/monodoc: version bump (1.2.4)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-util/monodoc')
-rw-r--r--dev-util/monodoc/ChangeLog7
-rw-r--r--dev-util/monodoc/files/digest-monodoc-1.2.43
-rw-r--r--dev-util/monodoc/monodoc-1.2.4.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/monodoc/ChangeLog b/dev-util/monodoc/ChangeLog
index 3d4166477ea9..0dc0dcfed9a2 100644
--- a/dev-util/monodoc/ChangeLog
+++ b/dev-util/monodoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/monodoc
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/ChangeLog,v 1.61 2007/04/22 13:38:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/ChangeLog,v 1.62 2007/06/21 23:51:52 jurek Exp $
+
+*monodoc-1.2.4 (21 Jun 2007)
+
+ 21 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> +monodoc-1.2.4.ebuild:
+ Version bump
22 Apr 2007; Tobias Scherbaum <dertobi123@gentoo.org>
monodoc-1.2.1.ebuild:
diff --git a/dev-util/monodoc/files/digest-monodoc-1.2.4 b/dev-util/monodoc/files/digest-monodoc-1.2.4
new file mode 100644
index 000000000000..90f018f70e9f
--- /dev/null
+++ b/dev-util/monodoc/files/digest-monodoc-1.2.4
@@ -0,0 +1,3 @@
+MD5 875bd8df4e7444f4e04f4dd58865c559 monodoc-1.2.4.zip 14646765
+RMD160 204730b37b4ee63c1c1126d7b007ee9133a9ffc2 monodoc-1.2.4.zip 14646765
+SHA256 0fc738185902d37edfef6055b9b6bc762d3217fb374cb191eb4dd79854bc0533 monodoc-1.2.4.zip 14646765
diff --git a/dev-util/monodoc/monodoc-1.2.4.ebuild b/dev-util/monodoc/monodoc-1.2.4.ebuild
new file mode 100644
index 000000000000..b46f56cbd409
--- /dev/null
+++ b/dev-util/monodoc/monodoc-1.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/monodoc-1.2.4.ebuild,v 1.1 2007/06/21 23:51:52 jurek Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Documentation for mono's .Net class library"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+RDEPEND=">=dev-lang/mono-1.1
+ www-client/lynx"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+PDEPEND="X? ( >=dev-util/mono-tools-1.1.17 )"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Install all our .dlls under $(libdir), not $(prefix)/lib
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ ${S}/engine/Makefile.am \
+ || die "sed failed"
+
+ sed -i -e 's:libdir=@prefix@/lib:libdir=@libdir@:' \
+ -i -e 's:${prefix}/lib:${libdir}:' \
+ ${S}/monodoc.pc.in \
+ || die "sed failed"
+
+ aclocal || die "aclocal failed"
+ automake || die "automake failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}