summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-27 13:37:56 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-27 13:37:56 +0000
commit32798a9ef9a5fbabc44320dcbc107272339df92f (patch)
treebf0772808102d595fc2c73c2e666944ba77ae89a /dev-util/mono-debugger
parentAdd missing dependency on libkworkspace, bug 354987 (diff)
downloadgentoo-2-32798a9ef9a5fbabc44320dcbc107272339df92f.tar.gz
gentoo-2-32798a9ef9a5fbabc44320dcbc107272339df92f.tar.bz2
gentoo-2-32798a9ef9a5fbabc44320dcbc107272339df92f.zip
Version bump for mono-2.10
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mono-debugger')
-rw-r--r--dev-util/mono-debugger/ChangeLog7
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.10.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-util/mono-debugger/ChangeLog b/dev-util/mono-debugger/ChangeLog
index d99c8a4bf3dd..488d972dc0c6 100644
--- a/dev-util/mono-debugger/ChangeLog
+++ b/dev-util/mono-debugger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mono-debugger
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.46 2011/01/29 17:06:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.47 2011/02/27 13:37:56 pacho Exp $
+
+*mono-debugger-2.10 (27 Feb 2011)
+
+ 27 Feb 2011; Pacho Ramos <pacho@gentoo.org> +mono-debugger-2.10.ebuild:
+ Version bump for mono-2.10
29 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
mono-debugger-2.8.1-r1.ebuild:
diff --git a/dev-util/mono-debugger/mono-debugger-2.10.ebuild b/dev-util/mono-debugger/mono-debugger-2.10.ebuild
new file mode 100644
index 000000000000..48028db679d1
--- /dev/null
+++ b/dev-util/mono-debugger/mono-debugger-2.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.10.ebuild,v 1.1 2011/02/27 13:37:56 pacho Exp $
+
+# bah, tests fail. Needs to be fixed ...
+RESTRICT="test"
+
+EAPI="2"
+
+inherit go-mono mono autotools flag-o-matic eutils
+
+DESCRIPTION="Debugger for .NET managed and unmanaged applications"
+HOMEPAGE="http://www.mono-project.com/"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+#Bundles jay
+# Binutils is needed for libbfd
+RDEPEND="!!=dev-lang/mono-2.2
+ sys-devel/binutils
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ !dev-lang/mercury"
+
+src_prepare() {
+ go-mono_src_prepare
+
+ # Allow compilation against system libbfd, bnc#662581
+ epatch "${FILESDIR}/${PN}-2.8-system-bfd.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # Let's go for extra safety to avoid runtime errors, until
+ # upstream applies it.
+ append-ldflags -Wl,--no-undefined
+
+ go-mono_src_configure \
+ --with-system-libbfd \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1 || die "Failed to build"
+}