summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-07-02 20:09:24 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-07-02 20:09:24 +0000
commit7dfc4ec4408c6a66891a372db477f91bd315c147 (patch)
tree5b2f0425dca6ab4dec9fff0da44a6dd35a89a79e /dev-util/mercurial
parentStable for HPPA too. (diff)
downloadgentoo-2-7dfc4ec4408c6a66891a372db477f91bd315c147.tar.gz
gentoo-2-7dfc4ec4408c6a66891a372db477f91bd315c147.tar.bz2
gentoo-2-7dfc4ec4408c6a66891a372db477f91bd315c147.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mercurial')
-rw-r--r--dev-util/mercurial/ChangeLog7
-rw-r--r--dev-util/mercurial/mercurial-1.3.ebuild120
2 files changed, 126 insertions, 1 deletions
diff --git a/dev-util/mercurial/ChangeLog b/dev-util/mercurial/ChangeLog
index 999cdaad7b9c..575e3c9e9db3 100644
--- a/dev-util/mercurial/ChangeLog
+++ b/dev-util/mercurial/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mercurial
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.98 2009/05/16 16:47:42 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.99 2009/07/02 20:09:24 nelchael Exp $
+
+*mercurial-1.3 (02 Jul 2009)
+
+ 02 Jul 2009; Krzysiek Pawlik <nelchael@gentoo.org> +mercurial-1.3.ebuild:
+ Version bump.
16 May 2009; Krzysiek Pawlik <nelchael@gentoo.org>
-mercurial-1.0.2.ebuild, -mercurial-1.2.ebuild:
diff --git a/dev-util/mercurial/mercurial-1.3.ebuild b/dev-util/mercurial/mercurial-1.3.ebuild
new file mode 100644
index 000000000000..4d297dc46327
--- /dev/null
+++ b/dev-util/mercurial/mercurial-1.3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.3.ebuild,v 1.1 2009/07/02 20:09:24 nelchael Exp $
+
+inherit bash-completion elisp-common flag-o-matic eutils distutils
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
+
+CDEPEND=">=dev-lang/python-2.4"
+RDEPEND="${CDEPEND}
+ bugzilla? ( dev-python/mysql-python )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${CDEPEND}
+ emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments )"
+
+PYTHON_MODNAME="${PN} hgext"
+SITEFILE="70${PN}-gentoo.el"
+
+src_compile() {
+ filter-flags -ftracer -ftree-vectorize
+
+ distutils_src_compile
+
+ if use emacs; then
+ cd "${S}"/contrib
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+
+ rm -rf contrib/{win32,macosx}
+}
+
+src_install() {
+ distutils_src_install
+
+ dobashcompletion contrib/bash_completion ${PN}
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+ fi
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
+ cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
+
+ dobin contrib/hgk
+ dobin contrib/hg-relink
+ dobin contrib/hg-ssh
+
+ rm -f contrib/hgk contrib/hg-relink contrib/hg-ssh
+
+ rm -f contrib/bash_completion
+ cp -r contrib "${D}"/usr/share/doc/${PF}/
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG=/usr/bin/hg
+EOF
+ doenvd "${T}/80mercurial"
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+src_test() {
+ local testdir="${T}/tests"
+ mkdir -p -m1777 "${testdir}" || die
+ cd "${S}/tests/"
+ rm -rf *svn* # Subversion tests fail with 1.5
+ rm -f test-archive # Fails due to verbose tar output changes
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ rm -f test-doctest* # doctest always fails with python 2.5.x
+ if ! has userpriv ${FEATURES}; then
+ einfo "Removing tests which require user privileges to succeed"
+ rm -f test-command-template # Test is broken when run as root
+ rm -f test-convert # Test is broken when run as root
+ rm -f test-lock-badness # Test is broken when run as root
+ rm -f test-permissions # Test is broken when run as root
+ rm -f test-pull-permission # Test is broken when run as root
+ fi
+ einfo "Running Mercurial tests ..."
+ python run-tests.py --tmpdir="${testdir}" || die "test failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-util/cvs"
+ elog " dev-util/darcs"
+ elog " dev-util/git"
+ elog " dev-util/monotone"
+ elog " dev-util/subversion"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}