summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-02-24 16:40:44 +0000
committerAron Griffis <agriffis@gentoo.org>2006-02-24 16:40:44 +0000
commit2230b113f7f6cc7668281a210d8af278e4b90341 (patch)
treef47c3fbcd5c9e91d66b2ef55d99cde539052a6f7 /dev-util/mercurial/mercurial-0.8.ebuild
parentAlpha stable (diff)
downloadgentoo-2-2230b113f7f6cc7668281a210d8af278e4b90341.tar.gz
gentoo-2-2230b113f7f6cc7668281a210d8af278e4b90341.tar.bz2
gentoo-2-2230b113f7f6cc7668281a210d8af278e4b90341.zip
Bump to 0.8 (from 0.7). #121908
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-util/mercurial/mercurial-0.8.ebuild')
-rw-r--r--dev-util/mercurial/mercurial-0.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/mercurial/mercurial-0.8.ebuild b/dev-util/mercurial/mercurial-0.8.ebuild
new file mode 100644
index 000000000000..9dba3f7fc69b
--- /dev/null
+++ b/dev-util/mercurial/mercurial-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-0.8.ebuild,v 1.1 2006/02/24 16:40:44 agriffis Exp $
+
+inherit distutils
+
+MY_PV=${PV//_p/.}
+
+DESCRIPTION="scalable distributed SCM"
+HOMEPAGE="http://www.selenic.com/mercurial/"
+SRC_URI="http://www.selenic.com/mercurial/release/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ app-text/asciidoc
+ app-text/xmlto"
+
+if [[ ${PV} == *_p* ]]; then
+ S=${WORKDIR}/mercurial-snapshot
+else
+ S=${WORKDIR}/${PN}-${MY_PV}
+fi
+
+src_compile() {
+ distutils_src_compile
+
+ cd doc
+ local x
+ for x in *.?.txt; do
+ asciidoc -d manpage -b docbook $x || die
+ xmlto man ${x%txt}xml || die
+ sed -nie '/./p' ${x%.*} || die
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc CONTRIBUTORS PKG-INFO README *.txt
+ cp hgweb*.cgi ${D}/usr/share/doc/${PF}/
+ cp -r contrib ${D}/usr/share/doc/${PF}/
+ doman doc/*.?
+}