summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-07-11 01:09:47 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-07-11 01:09:47 +0000
commit6feea655b712b769341be714a24d3b73c45bf68c (patch)
tree06a02b38d1125b9ab2e2c44a30bf01ed062d1b2a /dev-util/ltrace
parentBruce Locke's ebuild for tmpreaper. (diff)
downloadgentoo-2-6feea655b712b769341be714a24d3b73c45bf68c.tar.gz
gentoo-2-6feea655b712b769341be714a24d3b73c45bf68c.tar.bz2
gentoo-2-6feea655b712b769341be714a24d3b73c45bf68c.zip
Bruce Locke's ltrace ebuild.
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/files/digest-ltrace-0.3.151
-rw-r--r--dev-util/ltrace/ltrace-0.3.15.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/ltrace/files/digest-ltrace-0.3.15 b/dev-util/ltrace/files/digest-ltrace-0.3.15
new file mode 100644
index 000000000000..a271ec333a05
--- /dev/null
+++ b/dev-util/ltrace/files/digest-ltrace-0.3.15
@@ -0,0 +1 @@
+MD5 c9a7ac8bb645c6b91c295a94c965653e ltrace_0.3.15.tar.gz
diff --git a/dev-util/ltrace/ltrace-0.3.15.ebuild b/dev-util/ltrace/ltrace-0.3.15.ebuild
new file mode 100644
index 000000000000..58c2895febb7
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.3.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+
+S=${WORKDIR}/${P}
+FILE_VERSION="ltrace_0.3.15"
+DESCRIPTION="ltrace shows runtime library call information for dynamically linked executables"
+SRC_URI="http://ftp.debian.org/debian/pool/main/l/ltrace/${FILE_VERSION}.tar.gz"
+HOMEPAGE="http://packages.debian.org/unstable/utils/ltrace.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr
+
+ # pmake kept wanting to interpret ${CFLAGS} as params
+ try make CFLAGS=\"${CFLAGS} -Wall\" all
+
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+
+ # man page
+ gzip ${D}usr/share/man/man1/ltrace.1
+
+ # docs
+ rm -rvf ${D}usr/doc/
+ dodoc BUGS COPYING debian/changelog README TODO
+
+}
+