summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-29 13:02:02 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-29 13:02:02 +0000
commite057f3eda4e45afca1ba7a70b3d42f173ef69736 (patch)
tree6ec5b2912eb4a0bfe7407aeb620b202fee4cadaa /dev-util/lincvs
parentalsa-enabled digest (diff)
downloadgentoo-2-e057f3eda4e45afca1ba7a70b3d42f173ef69736.tar.gz
gentoo-2-e057f3eda4e45afca1ba7a70b3d42f173ef69736.tar.bz2
gentoo-2-e057f3eda4e45afca1ba7a70b3d42f173ef69736.zip
Enhanced new version with kde2 support
Diffstat (limited to 'dev-util/lincvs')
-rw-r--r--dev-util/lincvs/files/digest-lincvs-0.3.02
-rw-r--r--dev-util/lincvs/lincvs-0.3.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/lincvs/files/digest-lincvs-0.3.0 b/dev-util/lincvs/files/digest-lincvs-0.3.0
new file mode 100644
index 000000000000..b8f9c5855598
--- /dev/null
+++ b/dev-util/lincvs/files/digest-lincvs-0.3.0
@@ -0,0 +1,2 @@
+MD5 f6f6875aa6ba9fe675acffbf9238d5a7 lincvs-0.3-0-generic-src.tgz
+MD5 ea3c83b9ad56ca8702d8e91efae5c710 lincvs-0.3.patch-1.tgz
diff --git a/dev-util/lincvs/lincvs-0.3.0.ebuild b/dev-util/lincvs/lincvs-0.3.0.ebuild
new file mode 100644
index 000000000000..2bed766b0759
--- /dev/null
+++ b/dev-util/lincvs/lincvs-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-0.3.0.ebuild,v 1.1 2001/04/29 13:02:02 achim Exp $
+
+S=${WORKDIR}/LinCVS-0.3
+DESCRIPTION="A Graphical CVS Client"
+SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/${P}/${PN}-0.3-0-generic-src.tgz
+ http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/${P}/${PN}-0.3.patch-1.tgz"
+HOMEPAGE="http://www.lincvs.de"
+
+DEPEND="kde? ( >=kde-base/kdelibs-2.1.1 )
+ >=x11-libs/qt-x11-2.2.2"
+RDEPEND="$DEPEND
+ dev-utils/cvs"
+
+src_unpack () {
+
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}/src
+ patch diffview.cpp ${WORKDIR}/LinCVS-patch/diffview.patch
+
+}
+
+src_compile() {
+
+ if [ "`use kde`" ] ; then
+ sed "s:KDE2DIR:KDEDIR:g" Makefile.kde2 > Makefile
+ fi
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+
+ make
+
+}
+
+src_install () {
+
+ into /usr/X11R6
+ dobin LinCVS tools/*.sh
+ insinto /usr/X11R6/share/icons/lincvs
+ doins res/*.xpm
+ dodoc AUTHORS COPYING ChangeLog *.{txt,TXT}
+
+}
+
+