summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2002-12-30 12:15:27 +0000
committerMartin Holzer <mholzer@gentoo.org>2002-12-30 12:15:27 +0000
commitdb62219d5ea26495e0d219b47ab2575b1c2f38c9 (patch)
treeb16638dc140d0bffe2ff4098765cb058a9dd377e /dev-util/lincvs
parentUpdated SRC_URI. (diff)
downloadgentoo-2-db62219d5ea26495e0d219b47ab2575b1c2f38c9.tar.gz
gentoo-2-db62219d5ea26495e0d219b47ab2575b1c2f38c9.tar.bz2
gentoo-2-db62219d5ea26495e0d219b47ab2575b1c2f38c9.zip
Version bumped.
Diffstat (limited to 'dev-util/lincvs')
-rw-r--r--dev-util/lincvs/ChangeLog7
-rw-r--r--dev-util/lincvs/files/digest-lincvs-1.0.01
-rw-r--r--dev-util/lincvs/lincvs-1.0.0.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-util/lincvs/ChangeLog b/dev-util/lincvs/ChangeLog
index 45430562c490..73fc6ce4a61f 100644
--- a/dev-util/lincvs/ChangeLog
+++ b/dev-util/lincvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/lincvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.5 2002/12/30 12:00:51 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.6 2002/12/30 12:15:27 mholzer Exp $
+
+*lincvs-1.0.0 (30 Dec 2002)
+
+ 30 Dec 2002; Martin Holzer <mholzer@gentoo.org> lincvs-1.0.0.ebuild files/digest-lincvs-1.0.0 ChangeLog :
+ Version bumped.
*lincvs-0.9.90 (23 Jul 2002)
diff --git a/dev-util/lincvs/files/digest-lincvs-1.0.0 b/dev-util/lincvs/files/digest-lincvs-1.0.0
new file mode 100644
index 000000000000..4c85dad48d64
--- /dev/null
+++ b/dev-util/lincvs/files/digest-lincvs-1.0.0
@@ -0,0 +1 @@
+MD5 b81b2204f324c730d104f0b21bac992a lincvs-1.0.0-0-generic-src.tgz 540069
diff --git a/dev-util/lincvs/lincvs-1.0.0.ebuild b/dev-util/lincvs/lincvs-1.0.0.ebuild
new file mode 100644
index 000000000000..ca4edad48cf8
--- /dev/null
+++ b/dev-util/lincvs/lincvs-1.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.0.0.ebuild,v 1.1 2002/12/30 12:15:27 mholzer Exp $
+
+IUSE="kde"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Graphical CVS Client"
+SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/LinCVS/${P}/${P}-0-generic-src.tgz"
+HOMEPAGE="http://www.lincvs.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+LICENSE="GPL-2"
+
+DEPEND="kde? ( =kde-base/kdelibs-2* )
+ =x11-libs/qt-2*"
+
+RDEPEND="${DEPEND}
+ dev-util/cvs"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/nodefaults.diff
+
+}
+
+src_compile() {
+
+ if [ "`use kde`" ] ; then
+ myconf="${myconf} --with-kde2-support=yes"
+ else
+ myconf="${myconf} --with-kde2-support=no"
+ fi
+
+ libtoolize --copy --force
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --host=${CHOST} \
+ --with-qt-dir=/usr/qt/2 \
+ ${myconf} || die "configure failed"
+
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ${S}
+
+ make || die "make failed"
+
+}
+
+src_install () {
+
+ into /usr
+ dobin src/lincvs tools/*.sh
+ insinto /usr/share/doc/${P}
+ insopts -m 644
+ doins AUTHORS COPYING ChangeLog INSTALL \
+ README SSH.txt VERSION THANKS
+ dosym /usr/share/doc/${P} /usr/share/${PN}
+
+}
+
+