summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-13 09:51:44 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-13 09:51:44 +0000
commitbac55dc7fc045b7316e4a046e87c194c7a599ef4 (patch)
treee87a3d13e5f1e80d45167ba932b162c68a4fcda0 /dev-util/lincvs
parentadd arm keyword (diff)
downloadgentoo-2-bac55dc7fc045b7316e4a046e87c194c7a599ef4.tar.gz
gentoo-2-bac55dc7fc045b7316e4a046e87c194c7a599ef4.tar.bz2
gentoo-2-bac55dc7fc045b7316e4a046e87c194c7a599ef4.zip
fixed wrapper script; minor patch for typo in app.
Diffstat (limited to 'dev-util/lincvs')
-rw-r--r--dev-util/lincvs/ChangeLog7
-rw-r--r--dev-util/lincvs/files/digest-lincvs-1.1.2-r11
-rw-r--r--dev-util/lincvs/files/lincvs-1.1.2-gentoo.diff30
-rw-r--r--dev-util/lincvs/lincvs-1.1.2-r1.ebuild37
4 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/lincvs/ChangeLog b/dev-util/lincvs/ChangeLog
index 81dcea6fe518..2bd2060b3a6e 100644
--- a/dev-util/lincvs/ChangeLog
+++ b/dev-util/lincvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/lincvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.10 2003/03/08 00:49:18 alain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.11 2003/03/13 09:51:44 absinthe Exp $
+
+*lincvs-1.1.2-r1 (13 Mar 2003)
+
+ 13 Mar 2003; Dylan Carlson <dcarlson@gentoo.org> lincvs-1.1.2-r1.ebuild:
+ Fixed wrapper script, added patch for minor typo in program.
*lincvs-1.1.2 (7 Mar 2003)
diff --git a/dev-util/lincvs/files/digest-lincvs-1.1.2-r1 b/dev-util/lincvs/files/digest-lincvs-1.1.2-r1
new file mode 100644
index 000000000000..1fa1dfe4931e
--- /dev/null
+++ b/dev-util/lincvs/files/digest-lincvs-1.1.2-r1
@@ -0,0 +1 @@
+MD5 ef2df5fefc658de3abdd389eeaa40c79 lincvs-1.1.2-0-generic-src.tgz 432419
diff --git a/dev-util/lincvs/files/lincvs-1.1.2-gentoo.diff b/dev-util/lincvs/files/lincvs-1.1.2-gentoo.diff
new file mode 100644
index 000000000000..31c6a94a3799
--- /dev/null
+++ b/dev-util/lincvs/files/lincvs-1.1.2-gentoo.diff
@@ -0,0 +1,30 @@
+--- LinCVS.orig/lincvs 2003-03-13 04:08:16.000000000 -0500
++++ LinCVS/lincvs 2003-03-13 04:08:38.000000000 -0500
+@@ -1,9 +1,2 @@
+ #!/bin/sh
+-
+-echo Adapt the absolute path to LinCVS/lincvs.bin
+-echo and copy this startscript into a directory
+-echo of your PATH!
+-
+-#exec "/absolute_path_to_LinCVS/AppRun" "$@"
+-#for instance
+-#exec "/usr/local/apps/LinCVS/AppRun" "$@"
+\ No newline at end of file
++exec /usr/share/LinCVS/AppRun
+diff -ur src.orig/cmainwindow.ui src/cmainwindow.ui
+--- src.orig/cmainwindow.ui 2003-02-22 08:39:57.000000000 -0500
++++ src/cmainwindow.ui 2003-03-13 04:34:40.000000000 -0500
+@@ -102,10 +102,10 @@
+ <iconset></iconset>
+ </property>
+ <property name="text">
+- <string>&amp;Add project to workbech...</string>
++ <string>&amp;Add project to workbench...</string>
+ </property>
+ <property name="toolTip">
+- <string>Adds a new project to the workbech</string>
++ <string>Adds a new project to the workbench</string>
+ </property>
+ <property name="accel">
+ <string>F2</string>
diff --git a/dev-util/lincvs/lincvs-1.1.2-r1.ebuild b/dev-util/lincvs/lincvs-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..d02f4df88ff5
--- /dev/null
+++ b/dev-util/lincvs/lincvs-1.1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.1.2-r1.ebuild,v 1.1 2003/03/13 09:51:44 absinthe Exp $
+
+IUSE="kde"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Graphical CVS Client"
+SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/LinCVS/${P}/${P}-0-generic-src.tgz"
+HOMEPAGE="http://www.lincvs.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+LICENSE="GPL-2"
+
+DEPEND="kde? ( >=kde-base/kdelibs-2 )
+ >=x11-libs/qt-3.0.5
+ >=cvs-1.9"
+
+RDEPEND="${DEPEND}
+ dev-util/cvs"
+
+src_compile() {
+ # Patch wrapper script
+ patch -p0 < ${FILESDIR}/${PN}-${PV}-gentoo.diff
+
+ qmake -o Makefile lincvs.pro
+ sed -e "s/^\tstrip/#\tstrip/" -i Makefile
+ emake || die "make failed"
+ emake install || die "make install failed"
+}
+
+src_install () {
+ mkdir -p ${D}/usr/share
+ cp -pR ${S}/LinCVS ${D}/usr/share
+ dobin ${S}/LinCVS/lincvs
+}