summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-15 20:57:08 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-15 20:57:08 +0000
commit294ef79cfe8dcf38cba0010006b4d0ef17ce90af (patch)
treeb87ec2ffa7d803d5fccf5315a9947144f83d73b2 /dev-util/lincvs
parent2004.3 PPC udev-enabled cascading profile (diff)
downloadgentoo-2-294ef79cfe8dcf38cba0010006b4d0ef17ce90af.tar.gz
gentoo-2-294ef79cfe8dcf38cba0010006b4d0ef17ce90af.tar.bz2
gentoo-2-294ef79cfe8dcf38cba0010006b4d0ef17ce90af.zip
applying fix for gcc3.4 closing bug #63957
Diffstat (limited to 'dev-util/lincvs')
-rw-r--r--dev-util/lincvs/ChangeLog6
-rw-r--r--dev-util/lincvs/files/lincvs-1.3.2-gcc34.patch26
-rw-r--r--dev-util/lincvs/lincvs-1.3.2.ebuild16
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-util/lincvs/ChangeLog b/dev-util/lincvs/ChangeLog
index 1b65b481eb49..82d5cfbde454 100644
--- a/dev-util/lincvs/ChangeLog
+++ b/dev-util/lincvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/lincvs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.29 2004/07/11 12:43:32 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/ChangeLog,v 1.30 2004/09/15 20:57:08 morfic Exp $
+
+ 15 Sep 2004; Daniel Goller <morfic@gentoo.org>
+ +files/lincvs-1.3.2-gcc34.patch, lincvs-1.3.2.ebuild:
+ closing bug# 63957, applying patch conditionally, thanks to Halcy0n
11 Jul 2004; Carsten Lohrke <carlo@gentoo.org> lincvs-1.3.2.ebuild:
stable on x86
diff --git a/dev-util/lincvs/files/lincvs-1.3.2-gcc34.patch b/dev-util/lincvs/files/lincvs-1.3.2-gcc34.patch
new file mode 100644
index 000000000000..162fb1c411be
--- /dev/null
+++ b/dev-util/lincvs/files/lincvs-1.3.2-gcc34.patch
@@ -0,0 +1,26 @@
+diff -ur lincvs-1.3.2-orig/src/HistoryDialogImpl.cpp lincvs-1.3.2/src/HistoryDialogImpl.cpp
+--- lincvs-1.3.2-orig/src/HistoryDialogImpl.cpp 2004-09-13 21:43:43.004637569 -0400
++++ lincvs-1.3.2/src/HistoryDialogImpl.cpp 2004-09-13 21:52:53.844938240 -0400
+@@ -268,7 +268,8 @@
+ if (failed) return;
+ switch( cmd) {
+ case EDIT_REVISION_CMD: {
+- setPermission(QFile(tmpViewFileName),READABLE);//don't think you could change the file
++ QFile tmp(tmpViewFileName);
++ setPermission(tmp,READABLE);//don't think you could change the file
+ emit editFile(tmpViewFileName);
+ break;
+ }
+diff -ur lincvs-1.3.2-orig/src/LogDialogImpl.cpp lincvs-1.3.2/src/LogDialogImpl.cpp
+--- lincvs-1.3.2-orig/src/LogDialogImpl.cpp 2004-09-13 21:43:43.012637807 -0400
++++ lincvs-1.3.2/src/LogDialogImpl.cpp 2004-09-13 21:54:06.964101241 -0400
+@@ -806,7 +806,8 @@
+ break;
+ }
+ case EDIT_REVISION_CMD: {
+- setPermission(QFile(m_tmpDiffFileNameA),READABLE);//don't think you could change the file
++ QFile tmp(m_tmpDiffFileNameA);
++ setPermission(tmp,READABLE);//don't think you could change the file
+ emit editFile(m_tmpDiffFileNameA);
+ break;
+ }
diff --git a/dev-util/lincvs/lincvs-1.3.2.ebuild b/dev-util/lincvs/lincvs-1.3.2.ebuild
index cdc03dd0cd29..9d3dc88f7aca 100644
--- a/dev-util/lincvs/lincvs-1.3.2.ebuild
+++ b/dev-util/lincvs/lincvs-1.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.3.2.ebuild,v 1.3 2004/07/11 12:43:32 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.3.2.ebuild,v 1.4 2004/09/15 20:57:08 morfic Exp $
-inherit kde-functions
+inherit kde-functions eutils gcc
IUSE="kde"
@@ -22,6 +22,18 @@ RDEPEND="${DEPEND}
need-qt 3
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #apply both patches to compile with gcc-3.4.0 closing bug #63957
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/lincvs-${PV}-gcc34.patch
+ fi
+}
+
src_compile() {
qmake -o Makefile lincvs.pro
sed -e "s/^\tstrip/#\tstrip/" -i Makefile