summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-16 18:57:09 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-16 18:57:09 +0000
commitb56d4ac7948e4c26c8814e878cf0c0a4fd3fa013 (patch)
treedf5aa95ce04e1d55a2ec7b0d9d6f4718955a9b17 /dev-util/jarwizard
parentfilter -ftracer with gcc-3.4; bug #49472 (diff)
downloadgentoo-2-b56d4ac7948e4c26c8814e878cf0c0a4fd3fa013.tar.gz
gentoo-2-b56d4ac7948e4c26c8814e878cf0c0a4fd3fa013.tar.bz2
gentoo-2-b56d4ac7948e4c26c8814e878cf0c0a4fd3fa013.zip
style fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/jarwizard')
-rw-r--r--dev-util/jarwizard/jarwizard-2.34.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-util/jarwizard/jarwizard-2.34.ebuild b/dev-util/jarwizard/jarwizard-2.34.ebuild
index f2e34582d5f7..a5a8a3010e4c 100644
--- a/dev-util/jarwizard/jarwizard-2.34.ebuild
+++ b/dev-util/jarwizard/jarwizard-2.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/jarwizard/jarwizard-2.34.ebuild,v 1.4 2004/11/03 11:47:56 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jarwizard/jarwizard-2.34.ebuild,v 1.5 2005/07/16 18:57:09 axxo Exp $
inherit java-pkg
@@ -22,7 +22,7 @@ src_compile() {
if use jikes ; then
jikes -O -source 1.3 *.java
else
- javac -g:none -source 1.3 *.java
+ javac -g:none -target 1.3 -source 1.3 *.java
fi
}
@@ -33,7 +33,6 @@ src_install() {
java-pkg_dojar ${PN}.jar
echo "#!/bin/sh" > ${PN}
- echo "cd /usr/share/${PN}" >> ${PN}
- echo "java -cp lib/${PN}.jar JarWizard" >> ${PN}
+ echo "java -cp \$(java-config -p ${PN}) JarWizard" >> ${PN}
dobin ${PN}
}