summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-01 13:17:49 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-01 13:17:49 +0000
commit8685b3d9cffe086c7d7a8062e9aac37afe7b65a0 (patch)
treee56302145120eff400281a3c3083bc34bb519106 /dev-util/jarwizard
parentDevelopment branch version bump. (diff)
downloadgentoo-2-8685b3d9cffe086c7d7a8062e9aac37afe7b65a0.tar.gz
gentoo-2-8685b3d9cffe086c7d7a8062e9aac37afe7b65a0.tar.bz2
gentoo-2-8685b3d9cffe086c7d7a8062e9aac37afe7b65a0.zip
Version bump using generation 2 eclasses.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-util/jarwizard')
-rw-r--r--dev-util/jarwizard/ChangeLog7
-rw-r--r--dev-util/jarwizard/files/digest-jarwizard-2.503
-rw-r--r--dev-util/jarwizard/jarwizard-2.50.ebuild29
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-util/jarwizard/ChangeLog b/dev-util/jarwizard/ChangeLog
index 3facf0b1a55b..98a7fbd57799 100644
--- a/dev-util/jarwizard/ChangeLog
+++ b/dev-util/jarwizard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/jarwizard
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/jarwizard/ChangeLog,v 1.6 2007/02/22 02:13:30 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jarwizard/ChangeLog,v 1.7 2007/04/01 13:17:49 betelgeuse Exp $
+
+*jarwizard-2.50 (01 Apr 2007)
+
+ 01 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> +jarwizard-2.50.ebuild:
+ Version bump using generation 2 eclasses.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-util/jarwizard/files/digest-jarwizard-2.50 b/dev-util/jarwizard/files/digest-jarwizard-2.50
new file mode 100644
index 000000000000..6ab81b3a81aa
--- /dev/null
+++ b/dev-util/jarwizard/files/digest-jarwizard-2.50
@@ -0,0 +1,3 @@
+MD5 4a758f722345e8ad3d06624b0a53aef8 jarwizard_250_src.zip 169540
+RMD160 0f76b5af7b2fb16ad609313d82eeaf8e585e565b jarwizard_250_src.zip 169540
+SHA256 0f32f4d0e817674929d03cdb2e33c4c7dee8418ccbf8ef9dfb4266c068d39645 jarwizard_250_src.zip 169540
diff --git a/dev-util/jarwizard/jarwizard-2.50.ebuild b/dev-util/jarwizard/jarwizard-2.50.ebuild
new file mode 100644
index 000000000000..0aa757376155
--- /dev/null
+++ b/dev-util/jarwizard/jarwizard-2.50.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jarwizard/jarwizard-2.50.ebuild,v 1.1 2007/04/01 13:17:49 betelgeuse Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Takes the hassle out of creating executable JAR files for your Java programs"
+SRC_URI="mirror://sourceforge/jarwizard/${PN}_${PV/./}_src.zip"
+HOMEPAGE="http://www.geocities.com/chir_geo/jarc/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ java-ant_bsfix_one "${S}/nbproject/build-impl.xml"
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher ${PN} --main JarWizard
+}