summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-01 22:30:27 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-01 22:30:27 +0000
commitd4e239e59b98cf47bd76c24955b82ed157adcb88 (patch)
tree113cba74de67b9c8a2058d0198f2c013e07a9850 /dev-util/insight
parent- version bump to fix ulgy linux bugs (diff)
downloadgentoo-2-d4e239e59b98cf47bd76c24955b82ed157adcb88.tar.gz
gentoo-2-d4e239e59b98cf47bd76c24955b82ed157adcb88.tar.bz2
gentoo-2-d4e239e59b98cf47bd76c24955b82ed157adcb88.zip
old
Diffstat (limited to 'dev-util/insight')
-rw-r--r--dev-util/insight/insight-6.5.ebuild51
-rw-r--r--dev-util/insight/insight-6.6.ebuild73
-rw-r--r--dev-util/insight/insight-6.7.1.ebuild73
3 files changed, 0 insertions, 197 deletions
diff --git a/dev-util/insight/insight-6.5.ebuild b/dev-util/insight/insight-6.5.ebuild
deleted file mode 100644
index 29c6553f33e2..000000000000
--- a/dev-util/insight/insight-6.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.5.ebuild,v 1.9 2007/07/22 07:24:10 graaff Exp $
-
-inherit eutils
-
-IUSE="nls"
-
-DESCRIPTION="A graphical interface to the GNU debugger"
-HOMEPAGE="http://sourceware.org/insight/"
-LICENSE="GPL-2 LGPL-2"
-RDEPEND="sys-libs/ncurses
- x11-libs/libX11"
-DEPEND="x11-libs/libXt
- x11-libs/libX11
- nls? ( sys-devel/gettext )
- sys-libs/ncurses"
-
-SLOT="0"
-KEYWORDS="alpha amd64 ppc sparc x86"
-SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
-
-INSIGHTDIR="/opt/insight"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-# sed -i -e "s/relid'/relid/" {tcl,tk}/unix/configure
-}
-
-src_compile() {
- local myconf
- myconf="$(use_enable nls)"
-
- strip-linguas -i bfd/po opcodes/po
-
- ./configure --prefix="${INSIGHTDIR}" \
- --mandir="${D}${INSIGHTDIR}/share/man" \
- --infodir="${D}${INSIGHTDIR}/share/info" \
- ${myconf} || die
- emake || die
-}
-
-src_install () {
- make \
- prefix="${D}${INSIGHTDIR}" \
- mandir="${D}${INSIGHTDIR}/share/man" \
- infodir="${D}${INSIGHTDIR}/share/info" \
- install || die
- doenvd "${FILESDIR}/99insight"
-}
diff --git a/dev-util/insight/insight-6.6.ebuild b/dev-util/insight/insight-6.6.ebuild
deleted file mode 100644
index 3c31f95316f3..000000000000
--- a/dev-util/insight/insight-6.6.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.6.ebuild,v 1.2 2007/07/30 07:47:55 vapier Exp $
-
-inherit eutils flag-o-matic
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="A graphical interface to the GNU debugger"
-HOMEPAGE="http://sourceware.org/insight/"
-SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="nls"
-
-RDEPEND="sys-libs/ncurses
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-DESTDIR.patch
- epatch "${FILESDIR}"/${P}-burn-paths.patch
-}
-
-src_compile() {
- append-flags -fno-strict-aliasing # tcl code sucks
- strip-linguas -u bfd/po opcodes/po
- econf \
- --disable-werror \
- $(use_enable nls) \
- --enable-gdbtk \
- --disable-tui \
- --datadir=/usr/share/${PN} \
- || die
- emake || die
-}
-
-src_install() {
- # the tcl-related subdirs are not parallel safe
- emake -j1 DESTDIR="${D}" install || die
-
- # Don't install docs when building a cross-insight
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- dodoc gdb/gdbtk/{README,TODO}
- fi
-
- # the gui tcl code does not consider any of the configure
- # options given it ... instead, it requires the path to
- # be /usr/share/redhat/...
- mv "${D}"/usr/share/${PN}/redhat "${D}"/usr/share/ || die
-
- # scrub all the cruft we dont want
- local x
- cd "${D}"/usr/bin
- for x in * ; do
- [[ ${x} != *insight ]] && rm -f ${x}
- done
- cd "${D}"
- rm -rf usr/{include,man,share/{info,locale,man}}
- rm -rf usr/lib*
-}
diff --git a/dev-util/insight/insight-6.7.1.ebuild b/dev-util/insight/insight-6.7.1.ebuild
deleted file mode 100644
index 382ec15baf20..000000000000
--- a/dev-util/insight/insight-6.7.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.7.1.ebuild,v 1.1 2007/11/09 08:41:38 vapier Exp $
-
-inherit eutils flag-o-matic
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="A graphical interface to the GNU debugger"
-HOMEPAGE="http://sourceware.org/insight/"
-SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="nls"
-
-RDEPEND="sys-libs/ncurses
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-6.6-DESTDIR.patch
- epatch "${FILESDIR}"/${PN}-6.6-burn-paths.patch
-}
-
-src_compile() {
- append-flags -fno-strict-aliasing # tcl code sucks
- strip-linguas -u bfd/po opcodes/po
- econf \
- --disable-werror \
- $(use_enable nls) \
- --enable-gdbtk \
- --disable-tui \
- --datadir=/usr/share/${PN} \
- || die
- emake || die
-}
-
-src_install() {
- # the tcl-related subdirs are not parallel safe
- emake -j1 DESTDIR="${D}" install || die
-
- # Don't install docs when building a cross-insight
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- dodoc gdb/gdbtk/{README,TODO}
- fi
-
- # the gui tcl code does not consider any of the configure
- # options given it ... instead, it requires the path to
- # be /usr/share/redhat/...
- mv "${D}"/usr/share/${PN}/redhat "${D}"/usr/share/ || die
-
- # scrub all the cruft we dont want
- local x
- cd "${D}"/usr/bin
- for x in * ; do
- [[ ${x} != *insight ]] && rm -f ${x}
- done
- cd "${D}"
- rm -rf usr/{include,man,share/{info,locale,man}}
- rm -rf usr/lib*
-}