summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-23 03:50:47 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-23 03:50:47 +0000
commitde60fa5beff4525a381ec81549843f65bc9451ec (patch)
tree455b1727a256f646f3b9d974aaa161070c0d1ca9 /dev-util/indent/indent-2.2.11.ebuild
parentUpdate make_desktop_entry usage with the 5th arg #310763 by Jim Ramsay. (diff)
downloadgentoo-2-de60fa5beff4525a381ec81549843f65bc9451ec.tar.gz
gentoo-2-de60fa5beff4525a381ec81549843f65bc9451ec.tar.bz2
gentoo-2-de60fa5beff4525a381ec81549843f65bc9451ec.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-util/indent/indent-2.2.11.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.11.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/indent/indent-2.2.11.ebuild b/dev-util/indent/indent-2.2.11.ebuild
new file mode 100644
index 000000000000..bec79220560c
--- /dev/null
+++ b/dev-util/indent/indent-2.2.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.11.ebuild,v 1.1 2010/03/23 03:50:45 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="http://indent.isidore-it.eu/beautify.html"
+SRC_URI="http://${PN}.isidore-it.eu/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-segfault.patch
+}
+
+src_configure() {
+ # LINGUAS is used in aclocal.m4 (bug #94837)
+ unset LINGUAS
+ econf $(use_enable nls) || die "configure failed"
+}
+
+src_test() {
+ emake -C regression/ || die "regression tests failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install || die "make install failed"
+ dodoc AUTHORS NEWS README* ChangeLog*
+}