summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:20:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:20:19 +0000
commitd43a458c9251353772000a9fff343419151862b7 (patch)
treeb76918f7469df1def7cf668b066f3f8c556466f9 /dev-util/guile/guile-1.6.6.ebuild
parentadded patch to fix compilation on ppc, fixes bug #86533 (diff)
downloadgentoo-2-d43a458c9251353772000a9fff343419151862b7.tar.gz
gentoo-2-d43a458c9251353772000a9fff343419151862b7.tar.bz2
gentoo-2-d43a458c9251353772000a9fff343419151862b7.zip
make sure ppc compiles this with -O2 rather than -O3 which causes breakage. This should fix bug #85670 by Martin <monsorno@gmx.de>, which should somewhat solve bug #27716, but I leave that to Spanky and Alastair
(Portage version: 1.585-cvs)
Diffstat (limited to 'dev-util/guile/guile-1.6.6.ebuild')
-rw-r--r--dev-util/guile/guile-1.6.6.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/guile/guile-1.6.6.ebuild b/dev-util/guile/guile-1.6.6.ebuild
index 039083e537e9..31e44935a322 100644
--- a/dev-util/guile/guile-1.6.6.ebuild
+++ b/dev-util/guile/guile-1.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.6.ebuild,v 1.2 2005/01/28 11:03:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.6.ebuild,v 1.3 2005/04/06 20:20:19 seemant Exp $
inherit flag-o-matic eutils libtool
@@ -32,6 +32,10 @@ src_compile() {
epatch ${FILESDIR}/guile-amd64.patch
fi
+ if [ "${ARCH}" = "ppc" ]; then
+ replace-flags -O3 -O2
+ fi
+
if use ppc-macos ; then
elibtoolize
epatch ${FILESDIR}/guile-macos-posix.patch