summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-06 16:58:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-06 16:58:01 +0000
commited29b7bfb1c8fdf9a8b7eab93a62a80b1f0b4194 (patch)
treefa3557ddb58d4c442410f7ddc8352b3a02cb469b /dev-util/gtk-doc
parentversion bump (diff)
downloadgentoo-2-ed29b7bfb1c8fdf9a8b7eab93a62a80b1f0b4194.tar.gz
gentoo-2-ed29b7bfb1c8fdf9a8b7eab93a62a80b1f0b4194.tar.bz2
gentoo-2-ed29b7bfb1c8fdf9a8b7eab93a62a80b1f0b4194.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util/gtk-doc')
-rw-r--r--dev-util/gtk-doc/ChangeLog7
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.19.ebuild114
2 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/gtk-doc/ChangeLog b/dev-util/gtk-doc/ChangeLog
index b4b8a194c0d6..e1e08e723862 100644
--- a/dev-util/gtk-doc/ChangeLog
+++ b/dev-util/gtk-doc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gtk-doc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.181 2013/03/07 08:08:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.182 2013/06/06 16:58:01 pacho Exp $
+
+*gtk-doc-1.19 (06 Jun 2013)
+
+ 06 Jun 2013; Pacho Ramos <pacho@gentoo.org> +gtk-doc-1.19.ebuild:
+ Version bump
07 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -gtk-doc-1.17.ebuild,
-gtk-doc-1.17-r1.ebuild, -files/gtk-doc-1.17-buildir-docs.patch,
diff --git a/dev-util/gtk-doc/gtk-doc-1.19.ebuild b/dev-util/gtk-doc/gtk-doc-1.19.ebuild
new file mode 100644
index 000000000000..d7cfec3da475
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.19.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.19.ebuild,v 1.1 2013/06/06 16:58:01 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils elisp-common gnome2 python-single-r1 readme.gentoo
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug doc emacs highlight vim test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# dev-tex/tex4ht blocker needed due bug #315287
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6:2
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )
+ highlight? (
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ !vim? ( dev-util/source-highlight )
+ )
+ !!<dev-tex/tex4ht-20090611_p1038-r1
+"
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ app-text/yelp-tools
+ >=app-text/scrollkeeper-0.3.14
+ virtual/pkgconfig
+ test? ( app-text/scrollkeeper-dtd )
+"
+
+pkg_setup() {
+ DOC_CONTENTS="gtk-doc does no longer define global key bindings for Emacs.
+ You may set your own key bindings for \"gtk-doc-insert\" and
+ \"gtk-doc-insert-section\" in your ~/.emacs file."
+ SITEFILE=61${PN}-gentoo.el
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Always disable fop; it is unreliable enough that gtk-doc upstream
+ # commented it out by default, and if it's autodetected, it causes build
+ # failures in other packages, bug #403165
+ sed -e 's:test -n "@FOP@":test -n "":' \
+ -i gtkdoc-mkpdf.in || die "sed failed"
+
+ # Remove global Emacs keybindings.
+ epatch "${FILESDIR}/${PN}-1.8-emacs-keybindings.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ if use vim; then
+ G2CONF="${G2CONF} $(use_with highlight highlight vim)"
+ else
+ G2CONF="${G2CONF} $(use_with highlight highlight source-highlight)"
+ fi
+
+ gnome2_src_configure --with-xml-catalog="${EPREFIX}/etc/xml/catalog"
+}
+
+src_compile() {
+ gnome2_src_compile
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_fix_shebang "${ED}"/usr/bin/gtkdoc-depscan
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${ED}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${ED}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ readme.gentoo_print_elog
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}