summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-16 09:04:22 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-16 09:04:22 +0000
commit5b6e2f6ad857b421fedae2463c97f657a74642b9 (patch)
tree7aee013c84bd4cd0cc53e31a3294e0eec4c4b7aa /dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild
parentVersion bump, drop old (diff)
downloadgentoo-2-5b6e2f6ad857b421fedae2463c97f657a74642b9.tar.gz
gentoo-2-5b6e2f6ad857b421fedae2463c97f657a74642b9.tar.bz2
gentoo-2-5b6e2f6ad857b421fedae2463c97f657a74642b9.zip
Version bump, drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild')
-rw-r--r--dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild b/dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild
new file mode 100644
index 000000000000..6c2fd27fc20a
--- /dev/null
+++ b/dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc-am/gtk-doc-am-1.20.ebuild,v 1.1 2014/02/16 09:04:22 pacho Exp $
+
+EAPI=5
+GNOME_ORG_MODULE="gtk-doc"
+
+inherit gnome.org
+
+DESCRIPTION="Automake files from gtk-doc"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6"
+DEPEND="${RDEPEND}
+ !<dev-util/gtk-doc-${GNOME_ORG_PVP}"
+# pkg-config is used by gtkdoc-rebase at runtime
+# PDEPEND to avoid circular deps, bug 368301
+PDEPEND="virtual/pkgconfig"
+
+# This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
+RESTRICT="test"
+
+src_configure() {
+ # Duplicate autoconf checks so we don't have to call configure
+ local PERL=$(type -P perl)
+
+ test -n "${PERL}" || die "Perl not found!"
+ "${PERL}" -e "require v5.6.0" || die "perl >= 5.6.0 is required for gtk-doc"
+
+ # Replicate AC_SUBST
+ sed -e "s:@PERL@:${PERL}:g" -e "s:@VERSION@:${PV}:g" \
+ "${S}/gtkdoc-rebase.in" > "${S}/gtkdoc-rebase" || die "sed failed!"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ fperms +x gtkdoc-rebase
+ exeinto /usr/bin/
+ doexe gtkdoc-rebase
+
+ insinto /usr/share/aclocal
+ doins gtk-doc.m4
+}