summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-17 09:28:16 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-17 09:28:16 +0000
commitf3ec718cf2a38bd8c81737834976a0c3963daa45 (patch)
tree608b324aa0d052f36faead8d15eead229a482376 /dev-util/gruntspud
parentstable on x86; `` -> $(); tidy (diff)
downloadgentoo-2-f3ec718cf2a38bd8c81737834976a0c3963daa45.tar.gz
gentoo-2-f3ec718cf2a38bd8c81737834976a0c3963daa45.tar.bz2
gentoo-2-f3ec718cf2a38bd8c81737834976a0c3963daa45.zip
stop using packed jars, #63305
Diffstat (limited to 'dev-util/gruntspud')
-rw-r--r--dev-util/gruntspud/ChangeLog8
-rw-r--r--dev-util/gruntspud/Manifest4
-rw-r--r--dev-util/gruntspud/files/digest-gruntspud-0.4.6_beta-r11
-rw-r--r--dev-util/gruntspud/gruntspud-0.4.6_beta-r1.ebuild56
4 files changed, 67 insertions, 2 deletions
diff --git a/dev-util/gruntspud/ChangeLog b/dev-util/gruntspud/ChangeLog
index 975620c9da96..28c240dd8081 100644
--- a/dev-util/gruntspud/ChangeLog
+++ b/dev-util/gruntspud/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gruntspud
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gruntspud/ChangeLog,v 1.6 2004/08/30 18:35:15 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gruntspud/ChangeLog,v 1.7 2004/09/17 09:28:16 axxo Exp $
+
+*gruntspud-0.4.6_beta-r1 (17 Sep 2004)
+
+ 17 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
+ +gruntspud-0.4.6_beta-r1.ebuild:
+ stop using packed jars, #63305
30 Aug 2004; Chris Aniszczyk <zx@gentoo.org> gruntspud-0.4.6_beta.ebuild:
Marking x86
diff --git a/dev-util/gruntspud/Manifest b/dev-util/gruntspud/Manifest
index f209ab51ca50..21e909aae7da 100644
--- a/dev-util/gruntspud/Manifest
+++ b/dev-util/gruntspud/Manifest
@@ -1,4 +1,6 @@
-MD5 f5bc7263e002a35902a2eb96e5f9cd43 ChangeLog 769
MD5 e3169eef90de6dffe087849edd5d3292 gruntspud-0.4.6_beta.ebuild 1139
+MD5 f5bc7263e002a35902a2eb96e5f9cd43 ChangeLog 769
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 755e810ca0b00889a8ba4ba0e1cdaf08 gruntspud-0.4.6_beta-r1.ebuild 1475
MD5 5481dcb48a4eb119e5cb97441bed2eb1 files/digest-gruntspud-0.4.6_beta 74
+MD5 5481dcb48a4eb119e5cb97441bed2eb1 files/digest-gruntspud-0.4.6_beta-r1 74
diff --git a/dev-util/gruntspud/files/digest-gruntspud-0.4.6_beta-r1 b/dev-util/gruntspud/files/digest-gruntspud-0.4.6_beta-r1
new file mode 100644
index 000000000000..34e646407fc4
--- /dev/null
+++ b/dev-util/gruntspud/files/digest-gruntspud-0.4.6_beta-r1
@@ -0,0 +1 @@
+MD5 3db859ce36b23260c8c57bc3c3547955 gruntspud-0.4.6-beta-src.tgz 2027851
diff --git a/dev-util/gruntspud/gruntspud-0.4.6_beta-r1.ebuild b/dev-util/gruntspud/gruntspud-0.4.6_beta-r1.ebuild
new file mode 100644
index 000000000000..1d8bdfa2c640
--- /dev/null
+++ b/dev-util/gruntspud/gruntspud-0.4.6_beta-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gruntspud/gruntspud-0.4.6_beta-r1.ebuild,v 1.1 2004/09/17 09:28:16 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Gruntspud is a graphical CVS client written in Java."
+HOMEPAGE="http://gruntspud.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV/_/-}-src.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ sys-apps/sed
+ =dev-java/cvslib-bin-3.5
+ dev-java/netcomponents-bin
+ dev-java/log4j
+ dev-java/plugspud
+ dev-java/javahelp-bin
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+src_unpack() {
+ unpack ${A}
+ # Dirty workaround
+ cd ${S}
+ sed -i 's:compile_standalone,javahelp:compile_standalone:' build.xml || die "sed failed"
+ cd ${S}/lib/
+ rm -rf *.jar
+ java-pkg_jar-from cvslib-bin-3.5
+ java-pkg_jar-from netcomponents-bin
+ java-pkg_jar-from log4j log4j.jar log4j-1.2.6.jar
+ java-pkg_jar-from javahelp-bin jh.jar
+ java-pkg_jar-from plugspud
+}
+
+src_compile() {
+ local antflags=""
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant dist_standalone ${antflags} || die "compilation problem"
+}
+
+src_install() {
+ cd ${S}/dist/lib
+ mv GruntspudSA.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /usr/share/${PN}" >> ${PN}
+ echo "java -jar lib/${PN}.jar" >> ${PN}
+ dobin ${PN}
+}