summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-05-19 21:01:49 +0000
committerSebastian Pipping <sping@gentoo.org>2013-05-19 21:01:49 +0000
commit56cd4fe23c09d7dffed775167579bbd36624fbb7 (patch)
treec607f7e792fbbe2688d56f2c825e351df3c0c716 /dev-util/gprof2dot
parentFix typo for gnome-shell ebuilds #470686 (diff)
downloadgentoo-2-56cd4fe23c09d7dffed775167579bbd36624fbb7.tar.gz
gentoo-2-56cd4fe23c09d7dffed775167579bbd36624fbb7.tar.bz2
gentoo-2-56cd4fe23c09d7dffed775167579bbd36624fbb7.zip
dev-util/gprof2dot: 0_p20130517
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-util/gprof2dot')
-rw-r--r--dev-util/gprof2dot/ChangeLog11
-rw-r--r--dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild45
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-util/gprof2dot/ChangeLog b/dev-util/gprof2dot/ChangeLog
index 8932e3d7ae19..2e791c1472be 100644
--- a/dev-util/gprof2dot/ChangeLog
+++ b/dev-util/gprof2dot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gprof2dot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/ChangeLog,v 1.4 2012/03/15 20:16:55 sping Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/ChangeLog,v 1.5 2013/05/19 21:01:48 sping Exp $
+
+*gprof2dot-0_p20130517 (19 May 2013)
+
+ 19 May 2013; Sebastian Pipping <sping@gentoo.org>
+ +gprof2dot-0_p20130517.ebuild:
+ Update snapshot to Git HEAD of today. Python 3.x now supported upstream,
+ migrate to python-r1, fix/allow "import gprof2dot"
15 Mar 2012; Sebastian Pipping <sping@gentoo.org>
gprof2dot-0_p20100216.ebuild, +files/gprof2dot-0_p20100216-python3.patch:
diff --git a/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild b/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
new file mode 100644
index 000000000000..72a8b3e96d2e
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild,v 1.1 2013/05/19 21:01:49 sping Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE='xml'
+
+inherit eutils python-r1 python-utils-r1
+
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="http://code.google.com/p/jrfonseca/wiki/Gprof2Dot"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+_make_call_script() {
+ cat <<-EOF >"${D}/$1"
+ #! /usr/bin/env python
+ from gprof2dot import Main
+ Main().main()
+ EOF
+
+ fperms a+x "$1" || die
+}
+
+src_install() {
+ abi_specific_install() {
+ insinto "$(python_get_sitedir)"
+ doins ${PN}.py || die
+ python_optimize || die
+ }
+ python_parallel_foreach_impl abi_specific_install
+
+ dodir /usr/bin || die
+ _make_call_script /usr/bin/${PN} || die
+ python_replicate_script "${D}"/usr/bin/${PN} || die
+}