summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-06 12:50:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-06 12:50:36 +0000
commita0c7bd015d5cf99b77ed07542982b7b6ee01a20b (patch)
tree63befda4fccaa47a6aeb0af3941839574a71bee7 /dev-util/google-perftools
parentstable x86, bug 357277 (diff)
downloadgentoo-2-a0c7bd015d5cf99b77ed07542982b7b6ee01a20b.tar.gz
gentoo-2-a0c7bd015d5cf99b77ed07542982b7b6ee01a20b.tar.bz2
gentoo-2-a0c7bd015d5cf99b77ed07542982b7b6ee01a20b.zip
Version bump, thanks to Luca Longinotti in bug #357591.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/ChangeLog8
-rw-r--r--dev-util/google-perftools/files/google-perftools-1.7-syntax.patch13
-rw-r--r--dev-util/google-perftools/google-perftools-1.7.ebuild84
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index de84e6a27b71..c50a12511436 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.7 2011/01/09 21:01:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.8 2011/03/06 12:50:36 flameeyes Exp $
+
+*google-perftools-1.7 (06 Mar 2011)
+
+ 06 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +google-perftools-1.7.ebuild, +files/google-perftools-1.7-syntax.patch:
+ Version bump, thanks to Luca Longinotti in bug #357591.
09 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
-google-perftools-1.5.ebuild:
diff --git a/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch b/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch
new file mode 100644
index 000000000000..c9226a98a625
--- /dev/null
+++ b/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch
@@ -0,0 +1,13 @@
+Index: google-perftools-1.7/src/google/malloc_hook_c.h
+===================================================================
+--- google-perftools-1.7.orig/src/google/malloc_hook_c.h
++++ google-perftools-1.7/src/google/malloc_hook_c.h
+@@ -40,7 +40,7 @@
+ #include <stddef.h>
+ #include <sys/types.h>
+
+-// Annoying stuff for windows -- makes sure clients can import these functions
++/* Annoying stuff for windows -- makes sure clients can import these functions */
+ #ifndef PERFTOOLS_DLL_DECL
+ # ifdef _WIN32
+ # define PERFTOOLS_DLL_DECL __declspec(dllimport)
diff --git a/dev-util/google-perftools/google-perftools-1.7.ebuild b/dev-util/google-perftools/google-perftools-1.7.ebuild
new file mode 100644
index 000000000000..4225079fac7b
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-1.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.7.ebuild,v 1.1 2011/03/06 12:50:36 flameeyes Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="http://code.google.com/p/google-perftools/"
+SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="largepages +debug minimal" # test"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+# tests end up in an infinite loop, even without sandbox
+RESTRICT=test
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+
+ # use test && \
+ makeopts="${makeopts} noinst_PROGRAMS= "
+
+ # don't install _anything_ from the documentation, since it would
+ # install it in non-standard locations, and would just waste time.
+ makeopts="${makeopts} dist_doc_DATA= "
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-syntax.patch"
+}
+
+src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ $(use_enable debug debugalloc) \
+ $(use_enable minimal)
+}
+
+src_compile() {
+ emake ${makeopts} || die "emake failed"
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sanbox is enabled."
+ ewarn "See http://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install ${makeopts} || die "emake install failed"
+
+ # Remove libtool files since we dropped the static libraries
+ find "${D}" -name '*.la' -delete
+
+ dodoc README AUTHORS ChangeLog TODO NEWS || die
+ pushd doc
+ dohtml -r * || die
+ popd
+}