summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-20 19:54:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-20 19:54:18 +0000
commit5271806c7749dec1966e48e374a0c6739cb47059 (patch)
treeaebbd14b15a8e0d5769aa9518c4e0c98ce1074b6 /dev-util/google-perftools
parentStable for HPPA (bug #447968). (diff)
downloadgentoo-2-5271806c7749dec1966e48e374a0c6739cb47059.tar.gz
gentoo-2-5271806c7749dec1966e48e374a0c6739cb47059.tar.bz2
gentoo-2-5271806c7749dec1966e48e374a0c6739cb47059.zip
Re-add support for static-libs; use autotools-utils; add subslot.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/ChangeLog9
-rw-r--r--dev-util/google-perftools/google-perftools-2.0-r1.ebuild90
-rw-r--r--dev-util/google-perftools/google-perftools-2.0-r2.ebuild (renamed from dev-util/google-perftools/google-perftools-2.0.ebuild)47
3 files changed, 23 insertions, 123 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index b6d18b2316c3..a27189230496 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.24 2013/02/03 15:09:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.25 2013/02/20 19:54:18 flameeyes Exp $
+
+*google-perftools-2.0-r2 (20 Feb 2013)
+
+ 20 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +google-perftools-2.0-r2.ebuild, -google-perftools-2.0-r1.ebuild,
+ -google-perftools-2.0.ebuild:
+ Re-add support for static-libs; use autotools-utils; add subslot.
03 Feb 2013; Agostino Sarubbo <ago@gentoo.org> google-perftools-2.0-r1.ebuild:
Add ~ppc, wrt bug #429710
diff --git a/dev-util/google-perftools/google-perftools-2.0-r1.ebuild b/dev-util/google-perftools/google-perftools-2.0-r1.ebuild
deleted file mode 100644
index 58c62b20d634..000000000000
--- a/dev-util/google-perftools/google-perftools-2.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0-r1.ebuild,v 1.2 2013/02/03 15:09:08 ago Exp $
-
-EAPI=4
-
-MY_P="gperftools-${PV}"
-
-inherit toolchain-funcs eutils flag-o-matic
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="http://code.google.com/p/gperftools/"
-SRC_URI="http://gperftools.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="largepages +debug minimal test"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- makeopts="${makeopts} noinst_PROGRAMS= "
-
- # don't install _anything_ from the documentation, since it would
- # install it in non-standard locations, and would just waste time.
- makeopts="${makeopts} dist_doc_DATA= "
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${MY_P}+glibc-2.16.patch"
- epatch "${FILESDIR}/${MY_P}-32bit-barrier.patch"
-}
-
-src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
-
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --enable-fast-install \
- $(use_enable debug debugalloc) \
- $(use_enable minimal)
-}
-
-src_compile() {
- emake ${makeopts}
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sanbox is enabled."
- ewarn "See http://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install ${makeopts}
-
- # Remove libtool files since we dropped the static libraries
- find "${D}" -name '*.la' -delete
-
- dodoc README AUTHORS ChangeLog TODO NEWS
- pushd doc
- dohtml -r *
- popd
-}
diff --git a/dev-util/google-perftools/google-perftools-2.0.ebuild b/dev-util/google-perftools/google-perftools-2.0-r2.ebuild
index 6df04415bd00..dbb01111beab 100644
--- a/dev-util/google-perftools/google-perftools-2.0.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.0-r2.ebuild
@@ -1,32 +1,34 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0.ebuild,v 1.5 2013/01/20 23:32:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0-r2.ebuild,v 1.1 2013/02/20 19:54:18 flameeyes Exp $
-EAPI=4
+EAPI=5
MY_P="gperftools-${PV}"
-inherit toolchain-funcs eutils flag-o-matic
+inherit toolchain-funcs eutils flag-o-matic autotools-utils
DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
HOMEPAGE="http://code.google.com/p/gperftools/"
SRC_URI="http://gperftools.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="MIT"
-SLOT="0"
+SLOT="0/4"
# contains ASM code, with support for
# freebsd x86/amd64
# linux x86/amd64/ppc/ppc64/arm
# OSX ppc/amd64
# AIX ppc/ppc64
KEYWORDS="-* ~arm ~amd64 ~ppc64 ~x86 ~x86-fbsd"
-IUSE="largepages +debug minimal test"
+IUSE="largepages +debug minimal test static-libs"
DEPEND="sys-libs/libunwind"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+HTML_DOCS="doc"
+
pkg_setup() {
# set up the make options in here so that we can actually make use
# of them on both compile and install.
@@ -36,32 +38,25 @@ pkg_setup() {
# touching the build system (and thus without rebuilding
# autotools). Keep commented as long as it's restricted.
use test || \
- makeopts="${makeopts} noinst_PROGRAMS= "
-
- # don't install _anything_ from the documentation, since it would
- # install it in non-standard locations, and would just waste time.
- makeopts="${makeopts} dist_doc_DATA= "
+ MAKEOPTS+=" noinst_PROGRAMS= "
}
src_prepare() {
epatch "${FILESDIR}/${MY_P}+glibc-2.16.patch"
+ epatch "${FILESDIR}/${MY_P}-32bit-barrier.patch"
}
src_configure() {
use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
-
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --enable-fast-install \
- $(use_enable debug debugalloc) \
+ local myeconfargs=(
+ --htmldir=/usr/share/doc/${PF}/html
+ $(use_enable debug debugalloc)
$(use_enable minimal)
-}
+ )
-src_compile() {
- emake ${makeopts}
+ autotools-utils_src_configure
}
src_test() {
@@ -73,17 +68,5 @@ src_test() {
;;
esac
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install ${makeopts}
-
- # Remove libtool files since we dropped the static libraries
- find "${D}" -name '*.la' -delete
-
- dodoc README AUTHORS ChangeLog TODO NEWS
- pushd doc
- dohtml -r *
- popd
+ autotools-utils_src_test
}