summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-30 18:58:03 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-30 18:58:03 +0000
commit3a31bb8a6f58c3597f3edae42bf6ad7695a8c445 (patch)
tree5723675a368a113f44cf2b246be97f1cbf600bf7 /dev-util/gnustep-back/gnustep-back-0.8.8.ebuild
parentversion bump of the unstable series. (diff)
downloadgentoo-2-3a31bb8a6f58c3597f3edae42bf6ad7695a8c445.tar.gz
gentoo-2-3a31bb8a6f58c3597f3edae42bf6ad7695a8c445.tar.bz2
gentoo-2-3a31bb8a6f58c3597f3edae42bf6ad7695a8c445.zip
version bump of the unstable series.
Diffstat (limited to 'dev-util/gnustep-back/gnustep-back-0.8.8.ebuild')
-rw-r--r--dev-util/gnustep-back/gnustep-back-0.8.8.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/gnustep-back/gnustep-back-0.8.8.ebuild b/dev-util/gnustep-back/gnustep-back-0.8.8.ebuild
new file mode 100644
index 000000000000..e7d8a42eae97
--- /dev/null
+++ b/dev-util/gnustep-back/gnustep-back-0.8.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.8.ebuild,v 1.1 2003/07/30 18:57:50 raker Exp $
+
+IUSE=""
+
+inherit base gnustep
+
+DESCRIPTION="GNUstep GUI backend"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="=dev-util/gnustep-gui-${PV}*
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/freetype-2*
+ >=x11-base/xfree-4.3.0
+ >=x11-wm/windowmaker-0.80.1"
+
+PATCHES1="${FILESDIR}/${PN}-0.8.5.xft2.patch"
+GNUSTEPBACK_XFT=2
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ autoconf
+}
+
+src_compile() {
+
+ local myconf
+
+ # For a different graphics library... choose one
+ #
+ # myconf="--enable-graphics=xdps --with-name=xdps"
+ #
+ # -OR-
+ #
+ # make sure you have libart_lgpl installed and...
+ #
+ # myconf="--enable-graphics=art --with-name=art"
+
+ egnustepmake \
+ --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ --with-x ${myconf} || die "configure failed"
+}