summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-01-08 02:03:07 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-01-08 02:03:07 +0000
commite6ee75f3c26aa8410ded0764a719a85b768449fa (patch)
tree491c663f724b8ce7ca3863f44cc11cbf9c16e9f9 /dev-util/global
parentMarking anthy-9100d ppc64 for bug 204758 (diff)
downloadgentoo-2-e6ee75f3c26aa8410ded0764a719a85b768449fa.tar.gz
gentoo-2-e6ee75f3c26aa8410ded0764a719a85b768449fa.tar.bz2
gentoo-2-e6ee75f3c26aa8410ded0764a719a85b768449fa.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog9
-rw-r--r--dev-util/global/files/digest-global-5.6.23
-rw-r--r--dev-util/global/global-5.6.2.ebuild70
3 files changed, 80 insertions, 2 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index ce017904567b..d19c7ba9b4af 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.24 2007/08/27 17:15:47 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.25 2008/01/08 02:03:06 carlo Exp $
+
+*global-5.6.2 (08 Jan 2008)
+
+ 08 Jan 2008; Carsten Lohrke <carlo@gentoo.org> +global-5.6.2.ebuild:
+ Version bump.
*global-5.6.1 (27 Aug 2007)
diff --git a/dev-util/global/files/digest-global-5.6.2 b/dev-util/global/files/digest-global-5.6.2
new file mode 100644
index 000000000000..879b1b0e62af
--- /dev/null
+++ b/dev-util/global/files/digest-global-5.6.2
@@ -0,0 +1,3 @@
+MD5 c927bcd92dff1c092d43f7d78911fc9c global-5.6.2.tar.gz 739856
+RMD160 70862a2d79ec8fe97caa63416c1c945913fe0065 global-5.6.2.tar.gz 739856
+SHA256 988f5eb7770780c4b816bf38d26fa63fe85bef7ca27fd09cfb9c64b77466cb25 global-5.6.2.tar.gz 739856
diff --git a/dev-util/global/global-5.6.2.ebuild b/dev-util/global/global-5.6.2.ebuild
new file mode 100644
index 000000000000..18205bd75197
--- /dev/null
+++ b/dev-util/global/global-5.6.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.6.2.ebuild,v 1.1 2008/01/08 02:03:06 carlo Exp $
+
+inherit elisp-common
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in C, C++, Yacc, Java and assembler sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc vim emacs"
+
+
+RDEPEND="virtual/libc
+ vim? ( app-editors/vim )
+ emacs? ( virtual/emacs )"
+DEPEND="${DEPEND}
+ doc? ( sys-apps/texinfo )"
+
+SITEFILE=50gtags-gentoo.el
+
+src_compile() {
+ econf || die "econf failed"
+
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.txi
+ texi2html -o doc/global.html doc/global.txi
+ fi
+
+ if use emacs; then
+ elisp-comp *.el || die
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS LICENSE FAQ INSTALL NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}