summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-06-10 01:22:13 +0000
committerMike Gilbert <floppym@gentoo.org>2014-06-10 01:22:13 +0000
commit9ddbc13347f8f3388e26ea7de27a31c3ce99a934 (patch)
treead9188a7bd8a57fd105ff49e7a453d88f517f328 /dev-util/global
parentadjust version of dep hdf5, fixes Bug #512660 (diff)
downloadgentoo-2-9ddbc13347f8f3388e26ea7de27a31c3ce99a934.tar.gz
gentoo-2-9ddbc13347f8f3388e26ea7de27a31c3ce99a934.tar.bz2
gentoo-2-9ddbc13347f8f3388e26ea7de27a31c3ce99a934.zip
Version bumps (bug #512832). Ebuilds by Arfrever.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog9
-rw-r--r--dev-util/global/global-6.2.12.ebuild81
-rw-r--r--dev-util/global/global-6.3.ebuild81
3 files changed, 170 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 63dae36f1898..42db8e26ac4f 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/global
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.125 2014/06/08 11:11:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.126 2014/06/10 01:22:13 floppym Exp $
+
+*global-6.3 (10 Jun 2014)
+*global-6.2.12 (10 Jun 2014)
+
+ 10 Jun 2014; Mike Gilbert <floppym@gentoo.org> +global-6.2.12.ebuild,
+ +global-6.3.ebuild:
+ Version bumps (bug #512832). Ebuilds by Arfrever.
08 Jun 2014; Agostino Sarubbo <ago@gentoo.org> global-6.2.11.ebuild:
Stable for ppc, wrt bug #512456
diff --git a/dev-util/global/global-6.2.12.ebuild b/dev-util/global/global-6.2.12.ebuild
new file mode 100644
index 000000000000..179969e1029d
--- /dev/null
+++ b/dev-util/global/global-6.2.12.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.2.12.ebuild,v 1.1 2014/06/10 01:22:13 floppym Exp $
+
+EAPI="5"
+
+inherit autotools elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="sys-devel/libtool
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/global/global-6.3.ebuild b/dev-util/global/global-6.3.ebuild
new file mode 100644
index 000000000000..e245131d67ce
--- /dev/null
+++ b/dev-util/global/global-6.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.3.ebuild,v 1.1 2014/06/10 01:22:13 floppym Exp $
+
+EAPI="5"
+
+inherit autotools elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="sys-devel/libtool
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}