summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-24 17:16:18 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-24 17:16:18 +0000
commit8eacdf8b0eb171ed7584498f5bf9928749da61b5 (patch)
tree58a363180419924464e127886bf05b0dc82224b6 /dev-util/global
parentforce glib on (diff)
downloadgentoo-2-8eacdf8b0eb171ed7584498f5bf9928749da61b5.tar.gz
gentoo-2-8eacdf8b0eb171ed7584498f5bf9928749da61b5.tar.bz2
gentoo-2-8eacdf8b0eb171ed7584498f5bf9928749da61b5.zip
bump to 5.3
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/files/digest-global-5.33
-rw-r--r--dev-util/global/global-5.3.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index af70680a787f..c2dd2841d40e 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.20 2007/01/06 04:23:49 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.21 2007/01/24 17:16:18 antarus Exp $
+
+*global-5.3 (24 Jan 2007)
+
+ 24 Jan 2007; Alec Warner <antarus@gentoo.org> +global-5.3.ebuild:
+ bump to 5.3
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -global-4.8.2.ebuild,
-global-4.8.7.ebuild:
diff --git a/dev-util/global/files/digest-global-5.3 b/dev-util/global/files/digest-global-5.3
new file mode 100644
index 000000000000..cf66c16d8321
--- /dev/null
+++ b/dev-util/global/files/digest-global-5.3
@@ -0,0 +1,3 @@
+MD5 f0f89b036f95472211772d38fe567b72 global-5.3.tar.gz 721505
+RMD160 481d87c3e9faacaca4634df4ae26ae8163ea7b0d global-5.3.tar.gz 721505
+SHA256 acd5ffe8e527853d0ec0698b9d805547c2b9f851e7caf3d32ff67c92f03e3672 global-5.3.tar.gz 721505
diff --git a/dev-util/global/global-5.3.ebuild b/dev-util/global/global-5.3.ebuild
new file mode 100644
index 000000000000..ff687bcd4fee
--- /dev/null
+++ b/dev-util/global/global-5.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.3.ebuild,v 1.1 2007/01/24 17:16:18 antarus Exp $
+
+inherit elisp-common
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in C, C++, Yacc, Java and assembler sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc vim emacs"
+DEPEND="virtual/libc
+ doc? ( sys-apps/texinfo )
+ vim? ( app-editors/vim )
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50gtags-gentoo.el
+
+src_compile() {
+ econf || die "econf failed"
+
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.txi
+ texi2html -o doc/global.html doc/global.txi
+ fi
+
+ if use emacs; then
+ elisp-comp *.el || die
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS LICENSE FAQ INSTALL NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}