summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-03-15 02:57:36 +0000
committerMike Gilbert <floppym@gentoo.org>2014-03-15 02:57:36 +0000
commit44e230a0b553e899667c33a62d49509c1e3a4e6e (patch)
treef4836979401f7bdcb47f9dbefa1d2d1211277a96 /dev-util/global
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-44e230a0b553e899667c33a62d49509c1e3a4e6e.tar.gz
gentoo-2-44e230a0b553e899667c33a62d49509c1e3a4e6e.tar.bz2
gentoo-2-44e230a0b553e899667c33a62d49509c1e3a4e6e.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/global-6.2.11.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index ee655757e4d5..a5a2ae9baec3 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.122 2014/03/11 22:23:53 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.123 2014/03/15 02:57:36 floppym Exp $
+
+*global-6.2.11 (15 Mar 2014)
+
+ 15 Mar 2014; Mike Gilbert <floppym@gentoo.org> +global-6.2.11.ebuild:
+ Version bump. Ebuild by Arfrever.
11 Mar 2014; Mike Gilbert <floppym@gentoo.org> -global-6.2.8.ebuild,
-global-6.2.9.ebuild:
diff --git a/dev-util/global/global-6.2.11.ebuild b/dev-util/global/global-6.2.11.ebuild
new file mode 100644
index 000000000000..9804645ebbc9
--- /dev/null
+++ b/dev-util/global/global-6.2.11.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.2.11.ebuild,v 1.1 2014/03/15 02:57:36 floppym Exp $
+
+EAPI="5"
+
+inherit autotools elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="sys-devel/libtool
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}