summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-05 02:38:24 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-05 02:38:24 +0000
commit1d8ae4ddae44196812dfd95b332e08fb19ccc4b6 (patch)
tree2fbd2bc5ff6e1627fd629c3996e7fc5ea4c2a4c4 /dev-util/global
parentVersion bump (diff)
downloadgentoo-2-1d8ae4ddae44196812dfd95b332e08fb19ccc4b6.tar.gz
gentoo-2-1d8ae4ddae44196812dfd95b332e08fb19ccc4b6.tar.bz2
gentoo-2-1d8ae4ddae44196812dfd95b332e08fb19ccc4b6.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog9
-rw-r--r--dev-util/global/global-6.2.8.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 18a1edc0406a..b17918f5a3a1 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-util/global
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.106 2013/02/18 08:32:53 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.107 2013/03/05 02:38:24 floppym Exp $
+
+*global-6.2.8 (05 Mar 2013)
+
+ 05 Mar 2013; Mike Gilbert <floppym@gentoo.org> +global-6.2.8.ebuild:
+ Version bump. Ebuild by Arfrever.
*global-6.2.7-r1 (18 Feb 2013)
- 18 Feb 2013; Naohiro Aota +global-6.2.7-r1.ebuild:
+ 18 Feb 2013; Naohiro Aota <naota@gentoo.org> +global-6.2.7-r1.ebuild:
Do not drop all .la files. #457856
*global-6.2.7 (20 Jan 2013)
diff --git a/dev-util/global/global-6.2.8.ebuild b/dev-util/global/global-6.2.8.ebuild
new file mode 100644
index 000000000000..74509f332027
--- /dev/null
+++ b/dev-util/global/global-6.2.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.2.8.ebuild,v 1.1 2013/03/05 02:38:24 floppym Exp $
+
+EAPI="5"
+
+inherit elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="sys-devel/libtool
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}