summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-20 09:08:21 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-20 09:08:21 +0000
commit34b552bc48963794f8fa7194c31be04a0a8c45ce (patch)
tree773108f73e7dca4860e822bbcfb1342038d0895b /dev-util/glimmer
parentMissed the digest when committing the original ebuild (diff)
downloadgentoo-2-34b552bc48963794f8fa7194c31be04a0a8c45ce.tar.gz
gentoo-2-34b552bc48963794f8fa7194c31be04a0a8c45ce.tar.bz2
gentoo-2-34b552bc48963794f8fa7194c31be04a0a8c45ce.zip
updated requirments
Diffstat (limited to 'dev-util/glimmer')
-rw-r--r--dev-util/glimmer/glimmer-1.1.9.1.ebuild31
1 files changed, 8 insertions, 23 deletions
diff --git a/dev-util/glimmer/glimmer-1.1.9.1.ebuild b/dev-util/glimmer/glimmer-1.1.9.1.ebuild
index 877915e15ce1..2c23b36f50cf 100644
--- a/dev-util/glimmer/glimmer-1.1.9.1.ebuild
+++ b/dev-util/glimmer/glimmer-1.1.9.1.ebuild
@@ -3,34 +3,23 @@
# Author Tod M. Neidt <tneidt@fidnet.com>
# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
-#Remeber to add the proper Author line, above. Don't worry about the
-# fourth line; it'll get automatically fixed when the ebuild is checked in
-
-#Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}
A=glimmer-1.1.9-1.tar.gz
S=${WORKDIR}/glimmer-1.1.9-1
-
-#Short one-line description
DESCRIPTION="All-purpose gnome code editor."
-
-#Point to any required sources; these will be automatically downloaded
-# by Portage
SRC_URI="http://prdownloads.sourceforge.net/glimmer/${A}"
-
-#Homepage hasn't been moved to sourceforge yet.
HOMEPAGE="http://glimmer.sourceforge.net"
-#build-time dependencies
DEPEND=">=gnome-base/gnome-libs-1.2.13
>=gnome-base/ORBit-0.5.8
>=gnome-base/gnome-vfs-1.0
- >=gnome-base/gnome-print-0.25
- >=dev-lang/python-1.5.2
- >=dev-python/gnome-python-1.4.1"
+ >=gnome-base/gnome-print-0.25"
-#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-RDEPEND=""
+# These are requirements when build with --enable-python.
+# We should update this to build with --enable-python if USE=python,
+# some work might have to be done to make play with Python 2.X
+
+# >=dev-lang/python-1.5.2
+# >=dev-python/gnome-python-1.4.1"
src_compile() {
@@ -40,14 +29,10 @@ src_compile() {
./configure --disable-python --infodir=/opt/gnome/info --mandir=/opt/gnome/man --prefix=/opt/gnome --host=${CHOST} || die
emake || die
-
- #make || die
}
src_install () {
-
- make prefix=${D}/opt/gnome install || die
+ make DESTDIR=${D} install || die
dodoc AUTHORS ABOUT-NLS ChangeLog NEWS PROPS TODO README INSTALL COPYING
- # make DESTDIR=${D} install || die
}