summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
commitc542d1de8df85309d78a0e9a6b83dc7c3273fe86 (patch)
tree53d7c5a3ae720b5c8d123d4db74f0cd910ceab9d /dev-util/glade
parentre-add patch (diff)
downloadgentoo-2-c542d1de8df85309d78a0e9a6b83dc7c3273fe86.tar.gz
gentoo-2-c542d1de8df85309d78a0e9a6b83dc7c3273fe86.tar.bz2
gentoo-2-c542d1de8df85309d78a0e9a6b83dc7c3273fe86.zip
touchups
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/files/digest-glade-2.0.01
-rw-r--r--dev-util/glade/glade-0.6.4.ebuild30
-rw-r--r--dev-util/glade/glade-2.0.0-r1.ebuild23
-rw-r--r--dev-util/glade/glade-2.0.0.ebuild45
4 files changed, 15 insertions, 84 deletions
diff --git a/dev-util/glade/files/digest-glade-2.0.0 b/dev-util/glade/files/digest-glade-2.0.0
deleted file mode 100644
index b70f5107867c..000000000000
--- a/dev-util/glade/files/digest-glade-2.0.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 16b685dca1064a950d9f506b669cf859 glade-2.0.0.tar.bz2 1723210
diff --git a/dev-util/glade/glade-0.6.4.ebuild b/dev-util/glade/glade-0.6.4.ebuild
index 02b122cfacaa..7493df3cfa00 100644
--- a/dev-util/glade/glade-0.6.4.ebuild
+++ b/dev-util/glade/glade-0.6.4.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.6.4.ebuild,v 1.11 2003/04/12 18:06:03 foser Exp $
-
-IUSE="nls gnome bonobo"
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.6.4.ebuild,v 1.12 2003/04/23 16:17:08 vapier Exp $
inherit eutils
-S=${WORKDIR}/${P}
-DESCRIPTION="glade - GUI designer for GTK+/GNOME-1"
+DESCRIPTION="GUI designer for GTK+/GNOME-1"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/glade/${P}.tar.gz"
HOMEPAGE="http://glade.gnome.org/"
SLOT="1"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc ppc"
+KEYWORDS="x86 ppc sparc"
+IUSE="nls gnome bonobo"
DEPEND="=x11-libs/gtk+-1.2*
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
@@ -25,25 +23,14 @@ RDEPEND="${RDEPEND}
>=app-text/scrollkeeper-0.2"
src_compile() {
- local myconf
-
epatch ${FILESDIR}/${P}-autogen.sh.patch
- use gnome || myconf="--disable-gnome"
-
- use bonobo \
- && myconf="${myconf} --with-bonobo" \
- || myconf="${myconf} --without-bonobo"
-
- use nls || myconf="${myconf} --disable-nls"
-
- if [ "$DEBUG" ]
- then
- myconf="${myconf} --enable-debug"
- fi
-
econf \
--disable-gnome-db \
+ `use_enable gnome` \
+ `use_with bonobo`
+ `use_enable nls` \
+ `use_enable debug` \
${myconf} || die
emake || die
@@ -51,6 +38,5 @@ src_compile() {
src_install() {
einstall || die
-
dodoc AUTHORS COPYING* FAQ NEWS README* TODO
}
diff --git a/dev-util/glade/glade-2.0.0-r1.ebuild b/dev-util/glade/glade-2.0.0-r1.ebuild
index d8f5b4fb6c33..f31e8381dc35 100644
--- a/dev-util/glade/glade-2.0.0-r1.ebuild
+++ b/dev-util/glade/glade-2.0.0-r1.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-2.0.0-r1.ebuild,v 1.1 2003/04/22 13:37:19 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-2.0.0-r1.ebuild,v 1.2 2003/04/23 16:17:08 vapier Exp $
inherit gnome.org
-IUSE="gnome gnomedb"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Glade is a GUI Builder. This release is for GTK+ 2 and GNOME 2."
+DESCRIPTION="a GUI Builder. This release is for GTK+ 2 and GNOME 2."
HOMEPAGE="http://glade.gnome.org/"
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="gnome gnomedb"
DEPEND="=x11-libs/gtk+-2*
>=dev-libs/libxml2-2.4.1
@@ -34,20 +32,13 @@ src_unpack() {
}
src_compile() {
- local myconf=""
-
- use gnome \
- && myconf="--enable-gnome" \
- || myconf="--disable-gnome"
-
# note: ./configure --help and configure.in lists
# --disable-gnomedb, whereas the code looks for --disable-gnome-db
-
- use gnomedb \
- && myconf="${myconf} --enable-gnome-db" \
- || myconf="${myconf} --disable-gnome-db"
- econf ${myconf}
+ econf \
+ `use_enable gnome` \
+ `use_enable gnomedb gnome-db` \
+ || die
emake || die "Compilation failed"
}
diff --git a/dev-util/glade/glade-2.0.0.ebuild b/dev-util/glade/glade-2.0.0.ebuild
deleted file mode 100644
index 354c30f6a8eb..000000000000
--- a/dev-util/glade/glade-2.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-2.0.0.ebuild,v 1.1 2003/04/12 18:06:03 foser Exp $
-
-# FIXME : we could probably enable gnomedb support
-inherit gnome.org
-
-IUSE="gnome"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Glade is a GUI Builder. This release is for GTK+ 2 and GNOME 2."
-HOMEPAGE="http://glade.gnome.org/"
-
-SLOT="2"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc"
-
-DEPEND="=x11-libs/gtk+-2*
- >=dev-libs/libxml2-2.4.1
- gnome? ( >=gnome-base/libgnomeui-2.0.0
- >=gnome-base/libgnomecanvas-2.0.0
- >=gnome-base/libbonoboui-2.0.0 )"
-
-RDEPEND="${DEPEND}
- sys-devel/gettext
- >=dev-util/intltool-0.11
- >=app-text/scrollkeeper-0.2"
-
-src_compile() {
- local myconf=""
-
- use gnome || myconf="--disable-gnome"
-
- econf \
- --disable-gnome-db \
- ${myconf} || die "./configure failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- einstall || die "Installation failed"
-
- dodoc AUTHORS COPYING* FAQ NEWS README* TODO
-}