summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-03-22 20:44:15 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-03-22 20:44:15 +0000
commit931543f8bb133ceee9d5a2ed7bd64d8e43651a7e (patch)
tree19cd9f34c38e6c07de073abe5971804207e68eff /dev-util/glade
parentprune old version (diff)
downloadgentoo-2-931543f8bb133ceee9d5a2ed7bd64d8e43651a7e.tar.gz
gentoo-2-931543f8bb133ceee9d5a2ed7bd64d8e43651a7e.tar.bz2
gentoo-2-931543f8bb133ceee9d5a2ed7bd64d8e43651a7e.zip
version bump for 2.18 cycle
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/ChangeLog7
-rw-r--r--dev-util/glade/files/digest-glade-3.2.03
-rw-r--r--dev-util/glade/glade-3.2.0.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index 0426be472872..f20647f821a5 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/glade
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.61 2007/03/12 18:55:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.62 2007/03/22 20:44:15 compnerd Exp $
+
+*glade-3.2.0 (22 Mar 2007)
+
+ 22 Mar 2007; <compnerd@gentoo.org> +glade-3.2.0.ebuild:
+ Version bump for 2.18 cycle
12 Mar 2007; Raúl Porcel <armin76@gentoo.org> glade-2.12.1.ebuild:
x86 stable
diff --git a/dev-util/glade/files/digest-glade-3.2.0 b/dev-util/glade/files/digest-glade-3.2.0
new file mode 100644
index 000000000000..8e8db7cba24f
--- /dev/null
+++ b/dev-util/glade/files/digest-glade-3.2.0
@@ -0,0 +1,3 @@
+MD5 bee0aeb66b29ac40b24d9413aace15cc glade3-3.2.0.tar.bz2 1344693
+RMD160 85013a1b7daa570ac934b7d0fc985cea35e00a13 glade3-3.2.0.tar.bz2 1344693
+SHA256 4ca06cc1ab8670858b0295fc126aa39f059a0b90f0c399022770ee0b522eb35e glade3-3.2.0.tar.bz2 1344693
diff --git a/dev-util/glade/glade-3.2.0.ebuild b/dev-util/glade/glade-3.2.0.ebuild
new file mode 100644
index 000000000000..ce86a48bcc8a
--- /dev/null
+++ b/dev-util/glade/glade-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.2.0.ebuild,v 1.1 2007/03/22 20:44:15 compnerd Exp $
+
+inherit eutils gnome2
+MY_PN="glade3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GNOME GUI Builder"
+HOMEPAGE="http://glade.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="devhelp doc gnome python"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.10.0
+ >=dev-libs/libxml2-2.4
+ !alpha? ( !ppc64? ( devhelp? ( >=dev-util/devhelp-0.12 ) ) )
+ gnome? (
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonoboui-2.0
+ )
+ !alpha? ( python? ( >=dev-python/pygtk-2.10.0 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="AUTHORS BUGS ChangeLog HACKING INTERNALS MAINTAINERS NEWS README TODO"
+
+pkg_config() {
+ G2CONF="${G2CONF} $(use_with devhelp) $(use_enable gnome) $(use_enable python)"
+}