summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-05-15 09:50:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-05-15 09:50:59 +0000
commit986a64a20cd668992786ad0ef3bfa01e46fe3bc7 (patch)
tree61d6aa8e2c354a2a96b696ea6e433a7bb6159e18 /dev-util/gitosis-gentoo
parentkeyword ~x86-fbsd, bug #269298 (diff)
downloadgentoo-2-986a64a20cd668992786ad0ef3bfa01e46fe3bc7.tar.gz
gentoo-2-986a64a20cd668992786ad0ef3bfa01e46fe3bc7.tar.bz2
gentoo-2-986a64a20cd668992786ad0ef3bfa01e46fe3bc7.zip
Version bump with the cgit patch.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gitosis-gentoo')
-rw-r--r--dev-util/gitosis-gentoo/ChangeLog10
-rw-r--r--dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-util/gitosis-gentoo/ChangeLog b/dev-util/gitosis-gentoo/ChangeLog
index eacbce6e2ee1..6a1bcfb198ab 100644
--- a/dev-util/gitosis-gentoo/ChangeLog
+++ b/dev-util/gitosis-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gitosis-gentoo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.5 2008/11/24 01:26:33 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.6 2009/05/15 09:50:59 robbat2 Exp $
+
+*gitosis-gentoo-0.2_p20090515 (15 May 2009)
+
+ 15 May 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +gitosis-gentoo-0.2_p20090515.ebuild:
+ Version bump with the cgit patch.
24 Nov 2008; Robin H. Johnson <robbat2@gentoo.org>
gitosis-gentoo-0.2_p20080711.ebuild, gitosis-gentoo-0.2_p20081028.ebuild:
diff --git a/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
new file mode 100644
index 000000000000..dd6712a0cdb1
--- /dev/null
+++ b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild,v 1.1 2009/05/15 09:50:59 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_PV="20090515-1d768c5b87bbbe7ab1f3356c98943ed099bd40f3"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND_GIT=">=dev-util/git-1.5.6.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-util/gitosis"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_compile() {
+ pwd
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}
+
+pkg_postinst() {
+ einfo "If you need to actually use gitosis, you must unlock the git user."
+}