summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-28 10:47:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-28 10:47:40 +0000
commit10aa40bb5673403b593f3d522b5f81da62ed6dea (patch)
treed13fe5bac37f55957e5c1683b403bdea82aa2366 /dev-util/gitosis-gentoo
parentalpha/arm/ia64/sh/sparc stable #243850 (diff)
downloadgentoo-2-10aa40bb5673403b593f3d522b5f81da62ed6dea.tar.gz
gentoo-2-10aa40bb5673403b593f3d522b5f81da62ed6dea.tar.bz2
gentoo-2-10aa40bb5673403b593f3d522b5f81da62ed6dea.zip
Version bump per bug #236185, fixes for git-1.6.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'dev-util/gitosis-gentoo')
-rw-r--r--dev-util/gitosis-gentoo/ChangeLog8
-rw-r--r--dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20081028.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-util/gitosis-gentoo/ChangeLog b/dev-util/gitosis-gentoo/ChangeLog
index af27c75bea8b..8f2aaabd0c64 100644
--- a/dev-util/gitosis-gentoo/ChangeLog
+++ b/dev-util/gitosis-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gitosis-gentoo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.3 2008/07/17 20:12:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.4 2008/10/28 10:47:40 robbat2 Exp $
+
+*gitosis-gentoo-0.2_p20081028 (28 Oct 2008)
+
+ 28 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +gitosis-gentoo-0.2_p20081028.ebuild:
+ Version bump per bug #236185, fixes for git-1.6.
17 Jul 2008; Robin H. Johnson <robbat2@gentoo.org>
gitosis-gentoo-0.2_p20080711.ebuild:
diff --git a/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20081028.ebuild b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20081028.ebuild
new file mode 100644
index 000000000000..7ebef1543bd8
--- /dev/null
+++ b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20081028.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20081028.ebuild,v 1.1 2008/10/28 10:47:40 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_PV="20081025-acf867e8cd12f31dcf0f9fff92f3a3c34912b751"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND_GIT=">=dev-util/git-1.5.6.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND_GIT}
+ !dev-util/gitosis"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}