summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-02-22 13:57:25 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-02-22 13:57:25 +0000
commit48d4bfe5e900a28625cbad50d43b079db1da284a (patch)
treee4b058be1186a621726b52a0c7e35a01bfc520f5 /dev-util/eric
parentFix compilation with gcc-4. Add patch to fix compilation when LINGUAS (diff)
downloadgentoo-2-48d4bfe5e900a28625cbad50d43b079db1da284a.tar.gz
gentoo-2-48d4bfe5e900a28625cbad50d43b079db1da284a.tar.bz2
gentoo-2-48d4bfe5e900a28625cbad50d43b079db1da284a.zip
Clean up.
(Portage version: 2.0.54)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog7
-rw-r--r--dev-util/eric/eric-3.5.1.ebuild48
-rw-r--r--dev-util/eric/eric-3.6.1.ebuild60
-rw-r--r--dev-util/eric/eric-3.6.2.ebuild59
-rw-r--r--dev-util/eric/eric-3.7.0.ebuild59
-rw-r--r--dev-util/eric/eric-3.7.2.ebuild55
-rw-r--r--dev-util/eric/files/digest-eric-3.5.14
-rw-r--r--dev-util/eric/files/digest-eric-3.6.14
-rw-r--r--dev-util/eric/files/digest-eric-3.6.24
-rw-r--r--dev-util/eric/files/digest-eric-3.7.04
-rw-r--r--dev-util/eric/files/digest-eric-3.7.24
11 files changed, 6 insertions, 302 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 0b9bcbae17e0..598a11db9658 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.35 2006/01/24 19:37:14 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.36 2006/02/22 13:57:25 carlo Exp $
+
+ 22 Feb 2006; Carsten Lohrke <carlo@gentoo.org> -eric-3.5.1.ebuild,
+ -eric-3.6.1.ebuild, -eric-3.6.2.ebuild, -eric-3.7.0.ebuild,
+ -eric-3.7.2.ebuild:
+ Clean up.
24 Jan 2006; Markus Rothe <corsair@gentoo.org> eric-3.7.2-r1.ebuild:
Stable on ppc64
diff --git a/dev-util/eric/eric-3.5.1.ebuild b/dev-util/eric/eric-3.5.1.ebuild
deleted file mode 100644
index d6f793b1cf21..000000000000
--- a/dev-util/eric/eric-3.5.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.5.1.ebuild,v 1.5 2006/01/05 20:41:43 gustavoz Exp $
-
-inherit python
-
-DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
-HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
-SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
- linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
- linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
- linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~ppc ~amd64 ~ppc64"
-IUSE="idl"
-
-python_version
-IDIR="/usr/lib/python${PYVER}/site-packages/eric3/"
-
-DEPEND="virtual/libc
- sys-devel/libtool
- >=dev-python/qscintilla-1.54
- >=dev-python/sip-3.10.2
- >=dev-python/PyQt-3.12"
-
-RDEPEND=">=dev-python/qscintilla-1.54
- >=dev-lang/python-2.2.3
- >=dev-python/sip-3.10.2
- idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
-
-src_install() {
- python install.py \
- -b /usr/bin \
- -i ${D} \
- -c
- dodir "${IDIR}Tools"
- cp ${S}/patch_modpython.py ${D}/${IDIR}Tools
- dodoc HISTORY LICENSE.GPL THANKS eric/README*
-}
-
-pkg_postinst() {
- echo ""
- einfo "If you want to use eric3 with mod_python, have a look at"
- einfo "\"${IDIR}Tools/patch_modpython.py\"."
- echo ""
-}
diff --git a/dev-util/eric/eric-3.6.1.ebuild b/dev-util/eric/eric-3.6.1.ebuild
deleted file mode 100644
index 6e085e635723..000000000000
--- a/dev-util/eric/eric-3.6.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.6.1.ebuild,v 1.1 2005/01/29 19:26:51 carlo Exp $
-
-inherit python eutils
-
-MY_PV=${PV/"?.?_pre"/"snapshot-"}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
-HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
-SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
- linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
- linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
- linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
-#SRC_URI="http://www.die-offenbachs.de/detlev/snapshots/${PN}-${MY_PV}.tar.gz
-# linguas_de? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-de-${MY_PV}.tar.gz )
-# linguas_fr? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-fr-${MY_PV}.tar.gz )
-# linguas_ru? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-ru-${MY_PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc64"
-IUSE="idl"
-
-python_version
-IDIR="/usr/$(get_libdir)/python${PYVER}/site-packages/eric3/"
-
-DEPEND="virtual/libc
- sys-devel/libtool
- >=dev-python/qscintilla-1.54
- >=dev-python/sip-3.10.2
- >=dev-python/PyQt-3.12
- >=dev-python/pyxml-0.8.4"
-
-RDEPEND=">=dev-python/qscintilla-1.54
- >=dev-lang/python-2.2.3
- >=dev-python/sip-3.10.2
- >=dev-python/PyQt-3.12
- >=dev-python/pyxml-0.8.4
- idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
-
-LANGS="de fr ru"
-
-src_install() {
- python install.py \
- -b /usr/bin \
- -i ${D} \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -c
- cp ${S}/patch_modpython.py ${D}/${IDIR}
- dodoc HISTORY LICENSE.GPL THANKS eric/README*
-}
-
-pkg_postinst() {
- echo ""
- einfo "If you want to use eric3 with mod_python, have a look at"
- einfo "\"${IDIR}patch_modpython.py\"."
- echo ""
-} \ No newline at end of file
diff --git a/dev-util/eric/eric-3.6.2.ebuild b/dev-util/eric/eric-3.6.2.ebuild
deleted file mode 100644
index 7a868aa5a72b..000000000000
--- a/dev-util/eric/eric-3.6.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.6.2.ebuild,v 1.2 2005/03/06 21:49:44 carlo Exp $
-
-inherit python eutils
-
-MY_PV=${PV/"?.?_pre"/"snapshot-"}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
-HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
-SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
- linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
- linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
- linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
-#SRC_URI="http://www.die-offenbachs.de/detlev/snapshots/${PN}-${MY_PV}.tar.gz
-# linguas_de? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-de-${MY_PV}.tar.gz )
-# linguas_fr? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-fr-${MY_PV}.tar.gz )
-# linguas_ru? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-ru-${MY_PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc64"
-IUSE="idl"
-
-python_version
-IDIR="/usr/$(get_libdir)/python${PYVER}/site-packages/eric3/"
-
-DEPEND="sys-devel/libtool
- <dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4"
-
-RDEPEND="<dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4
- idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
-
-LANGS="de fr ru"
-
-src_install() {
- python install.py \
- -b /usr/bin \
- -i ${D} \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -c
- cp ${S}/patch_modpython.py ${D}/${IDIR}
- dodoc HISTORY LICENSE.GPL THANKS eric/README*
- make_desktop_entry "eric3 --nosplash" eric3 "${IDIR}icons/default/eric.png" "Development;IDE;Qt"
-}
-
-pkg_postinst() {
- echo ""
- einfo "If you want to use eric3 with mod_python, have a look at"
- einfo "\"${IDIR}patch_modpython.py\"."
- echo ""
-} \ No newline at end of file
diff --git a/dev-util/eric/eric-3.7.0.ebuild b/dev-util/eric/eric-3.7.0.ebuild
deleted file mode 100644
index 2ddc923b4cf1..000000000000
--- a/dev-util/eric/eric-3.7.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.7.0.ebuild,v 1.1 2005/06/06 01:43:33 fserb Exp $
-
-inherit python eutils
-
-MY_PV=${PV/"?.?_pre"/"snapshot-"}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
-HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
-SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
- linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
- linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
- linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
-#SRC_URI="http://www.die-offenbachs.de/detlev/snapshots/${PN}-${MY_PV}.tar.gz
-# linguas_de? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-de-${MY_PV}.tar.gz )
-# linguas_fr? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-fr-${MY_PV}.tar.gz )
-# linguas_ru? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-ru-${MY_PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="idl"
-
-python_version
-IDIR="/usr/$(get_libdir)/python${PYVER}/site-packages/eric3/"
-
-DEPEND="sys-devel/libtool
- <dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4"
-
-RDEPEND="<dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4
- idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
-
-LANGS="de fr ru"
-
-src_install() {
- python install.py \
- -b /usr/bin \
- -i ${D} \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -c
- cp ${S}/patch_modpython.py ${D}/${IDIR}
- dodoc HISTORY LICENSE.GPL THANKS eric/README*
- make_desktop_entry "eric3 --nosplash" eric3 "${IDIR}icons/default/eric.png" "Development;IDE;Qt"
-}
-
-pkg_postinst() {
- echo ""
- einfo "If you want to use eric3 with mod_python, have a look at"
- einfo "\"${IDIR}patch_modpython.py\"."
- echo ""
-} \ No newline at end of file
diff --git a/dev-util/eric/eric-3.7.2.ebuild b/dev-util/eric/eric-3.7.2.ebuild
deleted file mode 100644
index 46a30693285a..000000000000
--- a/dev-util/eric/eric-3.7.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.7.2.ebuild,v 1.1 2005/09/30 22:19:32 kloeri Exp $
-
-inherit python eutils
-
-MY_PV=${PV/"?.?_pre"/"snapshot-"}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
-HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
-SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
- linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
- linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
- linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="idl"
-
-python_version
-IDIR="/usr/$(get_libdir)/python${PYVER}/site-packages/eric3/"
-
-DEPEND="sys-devel/libtool
- <dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4"
-
-RDEPEND="<dev-python/qscintilla-1.6
- >=dev-python/sip-4.2
- >=dev-python/PyQt-3.14
- >=dev-python/pyxml-0.8.4
- idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
-
-LANGS="de fr ru"
-
-src_install() {
- python install.py \
- -b /usr/bin \
- -i ${D} \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -c
- cp ${S}/patch_modpython.py ${D}/${IDIR}
- dodoc HISTORY LICENSE.GPL THANKS eric/README*
- make_desktop_entry "eric3 --nosplash" eric3 "${IDIR}icons/default/eric.png" "Development;IDE;Qt"
-}
-
-pkg_postinst() {
- echo ""
- einfo "If you want to use eric3 with mod_python, have a look at"
- einfo "\"${IDIR}patch_modpython.py\"."
- echo ""
-}
diff --git a/dev-util/eric/files/digest-eric-3.5.1 b/dev-util/eric/files/digest-eric-3.5.1
deleted file mode 100644
index cb730083b8d8..000000000000
--- a/dev-util/eric/files/digest-eric-3.5.1
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 5eadd38ef54f9df4ed09a20074f27976 eric-3.5.1.tar.gz 1414585
-MD5 4b38f938efcdda806e88d14ae3cafa97 eric-i18n-de-3.5.1.tar.gz 184499
-MD5 3ef1a8afa047ab50de1fd0db240bc20e eric-i18n-fr-3.5.1.tar.gz 186974
-MD5 f67bf15d5c5555b0cb0b1c1efcf7ee31 eric-i18n-ru-3.5.1.tar.gz 194105
diff --git a/dev-util/eric/files/digest-eric-3.6.1 b/dev-util/eric/files/digest-eric-3.6.1
deleted file mode 100644
index ba341609c528..000000000000
--- a/dev-util/eric/files/digest-eric-3.6.1
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 cde50afe8d4cd91e3df2df7f5a6671a5 eric-3.6.1.tar.gz 1547027
-MD5 c85c4ce56c3cbae46396f99ca550dd77 eric-i18n-de-3.6.1.tar.gz 200606
-MD5 1aa64feeac82a22b1d3d8ce5a2ba728e eric-i18n-fr-3.6.1.tar.gz 203912
-MD5 bfc13f03eb4c704bf633853a7d8e0b1d eric-i18n-ru-3.6.1.tar.gz 211921
diff --git a/dev-util/eric/files/digest-eric-3.6.2 b/dev-util/eric/files/digest-eric-3.6.2
deleted file mode 100644
index 195acdcc3942..000000000000
--- a/dev-util/eric/files/digest-eric-3.6.2
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 db34965b338db7b41c71189d7c84149f eric-3.6.2.tar.gz 1547301
-MD5 7244234ca394fa68e66650b3bae2a954 eric-i18n-de-3.6.2.tar.gz 200604
-MD5 88acaa8e078750bc72e4572005ded62c eric-i18n-fr-3.6.2.tar.gz 203910
-MD5 4c82f9adfa100998772884c81ef6594e eric-i18n-ru-3.6.2.tar.gz 211911
diff --git a/dev-util/eric/files/digest-eric-3.7.0 b/dev-util/eric/files/digest-eric-3.7.0
deleted file mode 100644
index 5d81d75560be..000000000000
--- a/dev-util/eric/files/digest-eric-3.7.0
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 aa4ef47a892eff7a550e2289b8bd7bd4 eric-3.7.0.tar.gz 1732755
-MD5 089a6950db4c8307523c3a29501f24e1 eric-i18n-de-3.7.0.tar.gz 209536
-MD5 c2e28d1af84e1c9e8e44bffb6cb1687b eric-i18n-fr-3.7.0.tar.gz 213544
-MD5 65b491289b53db21e9b5f9062a9ae032 eric-i18n-ru-3.7.0.tar.gz 221140
diff --git a/dev-util/eric/files/digest-eric-3.7.2 b/dev-util/eric/files/digest-eric-3.7.2
deleted file mode 100644
index e45d861364af..000000000000
--- a/dev-util/eric/files/digest-eric-3.7.2
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 b0b1114cd823cb149844ac95dcf5b4ac eric-3.7.2.tar.gz 1733560
-MD5 b59380fc857d34d9abd57c5634d22467 eric-i18n-de-3.7.2.tar.gz 209704
-MD5 f7cb8d71f0de75dd1c532b4727b90e1b eric-i18n-fr-3.7.2.tar.gz 212608
-MD5 01245f09f337ba60cd1c39d7401bc628 eric-i18n-ru-3.7.2.tar.gz 221137