summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-12 10:08:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-12 10:08:16 +0000
commit3c2c823f12467a9fb6e8fc4a1be3de642a0b339f (patch)
tree1a8f613c4c1f025071544c7c817d4a2c6e11865a /dev-util/eric
parentalpha/ia64/sparc stable wrt #271889 (diff)
downloadgentoo-2-3c2c823f12467a9fb6e8fc4a1be3de642a0b339f.tar.gz
gentoo-2-3c2c823f12467a9fb6e8fc4a1be3de642a0b339f.tar.bz2
gentoo-2-3c2c823f12467a9fb6e8fc4a1be3de642a0b339f.zip
Version bump, remove sparc keywords
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.3.3.ebuild4
-rw-r--r--dev-util/eric/eric-4.3.4.ebuild4
-rw-r--r--dev-util/eric/eric-4.3.5.ebuild74
4 files changed, 85 insertions, 5 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 6c53c78adb6d..96dd303b1e5c 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.84 2009/06/13 21:16:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.85 2009/07/12 10:08:16 hwoarang Exp $
+
+*eric-4.3.5 (12 Jul 2009)
+
+ 12 Jul 2009; Markos Chandras <hwoarang@gentoo.org> eric-4.3.3.ebuild,
+ eric-4.3.4.ebuild, +eric-4.3.5.ebuild:
+ Version bump, drop ~sparc keywords because webkit use flag is masked on PyQt4
13 Jun 2009; Markos Chandras <hwoarang@gentoo.org> eric-4.3.3.ebuild,
eric-4.3.4.ebuild:
diff --git a/dev-util/eric/eric-4.3.3.ebuild b/dev-util/eric/eric-4.3.3.ebuild
index 47ed0ea04ac2..60624e4dc775 100644
--- a/dev-util/eric/eric-4.3.3.ebuild
+++ b/dev-util/eric/eric-4.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.3.ebuild,v 1.2 2009/06/13 21:16:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.3.ebuild,v 1.3 2009/07/12 10:08:16 hwoarang Exp $
EAPI="2"
@@ -23,7 +23,7 @@ SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
SLOT="4"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
DEPEND="dev-python/PyQt4[X,svg,webkit]
diff --git a/dev-util/eric/eric-4.3.4.ebuild b/dev-util/eric/eric-4.3.4.ebuild
index 09d5aa89faba..4b5a033e1f1a 100644
--- a/dev-util/eric/eric-4.3.4.ebuild
+++ b/dev-util/eric/eric-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.4.ebuild,v 1.2 2009/06/13 21:16:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.4.ebuild,v 1.3 2009/07/12 10:08:16 hwoarang Exp $
EAPI="2"
NEED_PYTHON=2.4
@@ -21,7 +21,7 @@ SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
SLOT="4"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
DEPEND="dev-python/PyQt4[X,svg,webkit]
diff --git a/dev-util/eric/eric-4.3.5.ebuild b/dev-util/eric/eric-4.3.5.ebuild
new file mode 100644
index 000000000000..021f3d46a95f
--- /dev/null
+++ b/dev-util/eric/eric-4.3.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.5.ebuild,v 1.1 2009/07/12 10:08:16 hwoarang Exp $
+
+EAPI="2"
+NEED_PYTHON=2.4
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://eric-ide.python-projects.org/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )
+ linguas_zh_CN? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-zh_CN.GB2312-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4[svg,webkit,X]
+ >=dev-python/qscintilla-python-2.2[qt4]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+src_prepare() {
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well."
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}