summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-29 23:54:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-29 23:54:48 +0000
commit9120c2c4ddf4978cf1040148e02a8a5f654ff17a (patch)
treef2a82347f3c031079fa2c15c1625a4e76e414f3a /dev-util/elfkickers
parentVersion bump. 4.3.3 stable on x86. (diff)
downloadgentoo-2-9120c2c4ddf4978cf1040148e02a8a5f654ff17a.tar.gz
gentoo-2-9120c2c4ddf4978cf1040148e02a8a5f654ff17a.tar.bz2
gentoo-2-9120c2c4ddf4978cf1040148e02a8a5f654ff17a.zip
cleanup and add amd64 support
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util/elfkickers')
-rw-r--r--dev-util/elfkickers/elfkickers-2.0a.ebuild48
1 files changed, 23 insertions, 25 deletions
diff --git a/dev-util/elfkickers/elfkickers-2.0a.ebuild b/dev-util/elfkickers/elfkickers-2.0a.ebuild
index 19f77444ec5d..85ea842921b1 100644
--- a/dev-util/elfkickers/elfkickers-2.0a.ebuild
+++ b/dev-util/elfkickers/elfkickers-2.0a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/elfkickers-2.0a.ebuild,v 1.11 2004/11/11 16:45:52 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/elfkickers-2.0a.ebuild,v 1.12 2005/03/29 23:54:48 vapier Exp $
inherit eutils
@@ -13,36 +13,34 @@ SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc hppa ~mips"
-IUSE=""
+KEYWORDS="amd64 hppa ~mips sparc x86"
+IUSE="doc"
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
- # custom made patch to keep the compiler warnings down
- epatch ${FILESDIR}/${P}.diff
-}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.diff
-src_compile() {
- emake -C ebfc
- emake -C elfls
- emake -C elftoc
- emake -C rebind
- emake -C sstrip
- # emake -C tiny
+ sed -i -e '/^SUBDIRS/s:tiny::' Makefile
+ use x86 || sed -i -e '/^SUBDIRS/s:ebfc::' Makefile
}
src_install() {
- cd ${S}
- mv -f ebfc/README README.ebfc
- mv -f elfls/README README.elfls
- mv -f elftoc/README README.elftoc
- mv -f rebind/README README.rebind
- mv -f sstrip/README README.sstrip
- insinto /usr
- dobin ebfc/ebfc sstrip/sstrip elfls/elfls elftoc/elftoc rebind/rebind
+ for d in elfls elftoc rebind sstrip ; do
+ newdoc ${d}/README README.${d}
+ dobin ${d}/${d} || die "dobin ${d} failed"
+ done
+ if use x86 ; then
+ newdoc ebfc/README README.ebfc
+ dobin ebfc/ebfc || die "dobin ebfc failed"
+ fi
+
doman */*.1
- dodoc Changelog README
- dodoc README.ebfc README.elfls README.elftoc README.rebind README.sstrip ebfc/elfparts.txt
+ dodoc Changelog README ebfc/elfparts.txt
+ if use doc ; then
+ docinto tiny
+ dodoc tiny/*.asm
+ fi
}