summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-11 21:34:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-11 21:34:59 +0000
commit7e2a543a9797c02a90f51609ee7519513a956393 (patch)
treee8ab56fbaa6031d84c552ce71127c541ff06e680 /dev-util/eggy/eggy-0.3.3.ebuild
parentstable x86, bug 300243 (diff)
downloadgentoo-2-7e2a543a9797c02a90f51609ee7519513a956393.tar.gz
gentoo-2-7e2a543a9797c02a90f51609ee7519513a956393.tar.bz2
gentoo-2-7e2a543a9797c02a90f51609ee7519513a956393.zip
Initial commit of eggy IDE, fixes bug #296147
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eggy/eggy-0.3.3.ebuild')
-rw-r--r--dev-util/eggy/eggy-0.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/eggy/eggy-0.3.3.ebuild b/dev-util/eggy/eggy-0.3.3.ebuild
new file mode 100644
index 000000000000..078977364d3a
--- /dev/null
+++ b/dev-util/eggy/eggy-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eggy/eggy-0.3.3.ebuild,v 1.1 2010/01/11 21:34:59 hwoarang Exp $
+
+EAPI="2"
+NEED_PYTHON=2.4
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="An IDE/editor for several programming languages, including Python, Java, C, Perl and others"
+HOMEPAGE="http://eggy.yolky.org/eggy/default/about"
+SRC_URI="http://eggy.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/PyQt4[X]
+ dev-python/qscintilla-python
+ dev-python/chardet"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # remove the bundled chardet library
+ sed -i "s:'eggy\\.chardet', ::" setup.py || die "sed failed"
+ rm -rf ${P}/${PN}/chardet || die "rm failed"
+ distutils_src_prepare
+}