summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-12-16 14:32:52 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-12-16 14:32:52 +0000
commitb0264f219693b621175b92a1dd7edc90e5347f03 (patch)
tree59d8fd8a1fc947cdb2cdb59e4730b36c83dc7af0 /dev-util/eclipse-pydev-bin
parent Added image blending patch for ppc, possibly other big-endian arches. Fixes ... (diff)
downloadgentoo-2-b0264f219693b621175b92a1dd7edc90e5347f03.tar.gz
gentoo-2-b0264f219693b621175b92a1dd7edc90e5347f03.tar.bz2
gentoo-2-b0264f219693b621175b92a1dd7edc90e5347f03.zip
New package
Diffstat (limited to 'dev-util/eclipse-pydev-bin')
-rw-r--r--dev-util/eclipse-pydev-bin/ChangeLog10
-rw-r--r--dev-util/eclipse-pydev-bin/Manifest2
-rw-r--r--dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild37
-rw-r--r--dev-util/eclipse-pydev-bin/metadata.xml24
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/eclipse-pydev-bin/ChangeLog b/dev-util/eclipse-pydev-bin/ChangeLog
new file mode 100644
index 000000000000..6332ab28c3fd
--- /dev/null
+++ b/dev-util/eclipse-pydev-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/eclipse-pydev-bin
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-pydev-bin/ChangeLog,v 1.1 2004/12/16 14:32:52 chrb Exp $
+
+*eclipse-pydev-bin-0.8.0 (16 Dec 2004)
+
+ 16 Dec 2004; Chris Bainbridge <chrb@gentoo.org> +metadata.xml,
+ +eclipse-pydev-bin-0.8.0.ebuild:
+ New package
+
diff --git a/dev-util/eclipse-pydev-bin/Manifest b/dev-util/eclipse-pydev-bin/Manifest
new file mode 100644
index 000000000000..2adee3e8820d
--- /dev/null
+++ b/dev-util/eclipse-pydev-bin/Manifest
@@ -0,0 +1,2 @@
+MD5 e9acef3d596f4e77197e6377e45821c5 eclipse-pydev-bin-0.8.0.ebuild 872
+MD5 6d86162ec19124b5cb9299cf7559cd63 files/digest-eclipse-pydev-bin-0.8.0 61
diff --git a/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild b/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild
new file mode 100644
index 000000000000..975d497d5ae1
--- /dev/null
+++ b/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-pydev-bin/eclipse-pydev-bin-0.8.0.ebuild,v 1.1 2004/12/16 14:32:52 chrb Exp $
+
+inherit eclipse-ext
+
+MY_PV=${PV//\./_}
+
+DESCRIPTION="Python Development Tools for Eclipse"
+HOMEPAGE="http://http://pydev.sourceforge.net"
+SRC_URI="mirror://sourceforge/pydev/pydev_${MY_PV}.zip"
+SLOT="1"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-util/eclipse-sdk-3.0
+ dev-lang/python"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+
+src_compile() {
+ einfo "${P} is a binary package"
+}
+
+src_install () {
+ eclipse-ext_require-slot 3 || die "Failed to find suitable Eclipse installation"
+
+ eclipse-ext_create-ext-layout binary || die "Failed to create layout"
+
+ eclipse-ext_install-features features/* || die "Failed to install features"
+ eclipse-ext_install-plugins plugins/* || die "Failed to install plugins"
+}
diff --git a/dev-util/eclipse-pydev-bin/metadata.xml b/dev-util/eclipse-pydev-bin/metadata.xml
new file mode 100644
index 000000000000..5118f8bcf4b6
--- /dev/null
+++ b/dev-util/eclipse-pydev-bin/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>dev-tools</herd>
+<longdescription>
+So, first thing... what is Pydev?
+
+PyDev is featured as a plugin for eclipse for editing, running and
+debugging Python scripts. It has already proven stable, even though it
+has still not reached version 1.0. Some features provided are:
+
+Code Completion (disabled by default - check the preferences page.)
+Refactoring with bicycle repair man
+Outline
+Find definition (powered by bicycle repair man)
+Debugger
+Content Assistant
+Code Coverage
+
+Pydev is licensed under the Common Public License and is implemented in java
+as a set of plugins to the Eclipse platform.
+</longdescription>
+</pkgmetadata>