summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-10-08 17:59:52 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-10-08 17:59:52 +0000
commitd40602ec0ff7c99f8485f6aca7a350ca700f444b (patch)
treea9bcbeb0f5f44b8636c90e859bb1732cc3c88947 /dev-util/dialog/dialog-1.1.20070930.ebuild
parentUpdate SLOT and add info, kill old (diff)
downloadgentoo-2-d40602ec0ff7c99f8485f6aca7a350ca700f444b.tar.gz
gentoo-2-d40602ec0ff7c99f8485f6aca7a350ca700f444b.tar.bz2
gentoo-2-d40602ec0ff7c99f8485f6aca7a350ca700f444b.zip
Add USE=nls, bug #195078
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-util/dialog/dialog-1.1.20070930.ebuild')
-rw-r--r--dev-util/dialog/dialog-1.1.20070930.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/dialog/dialog-1.1.20070930.ebuild b/dev-util/dialog/dialog-1.1.20070930.ebuild
index 4dcd12761ec7..33ea26af1075 100644
--- a/dev-util/dialog/dialog-1.1.20070930.ebuild
+++ b/dev-util/dialog/dialog-1.1.20070930.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.1.20070930.ebuild,v 1.1 2007/10/06 15:58:57 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.1.20070930.ebuild,v 1.2 2007/10/08 17:59:52 truedfx Exp $
inherit eutils
@@ -13,10 +13,12 @@ SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="examples unicode"
+IUSE="examples nls unicode"
-DEPEND=">=app-shells/bash-2.04-r3
+RDEPEND=">=app-shells/bash-2.04-r3
>=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
pkg_setup() {
if use unicode && ! built_with_use sys-libs/ncurses unicode; then
@@ -30,7 +32,8 @@ pkg_setup() {
src_compile() {
use unicode && ncursesw="w"
- econf "--with-ncurses${ncursesw}" || die "configure failed"
+ econf $(use_enable nls) \
+ "--with-ncurses${ncursesw}" || die "configure failed"
emake || die "build failed"
}