summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-09-21 14:35:33 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-09-21 14:35:33 +0000
commit0869296a15ba2a147d21e4f4689bdf7fa0e8b873 (patch)
tree772ae656972806fa77fd77d05ca18efe9e2e63d1 /dev-util/dialog/dialog-1.0.20040731.ebuild
parentdep fix (Manifest recommit) (diff)
downloadgentoo-2-0869296a15ba2a147d21e4f4689bdf7fa0e8b873.tar.gz
gentoo-2-0869296a15ba2a147d21e4f4689bdf7fa0e8b873.tar.bz2
gentoo-2-0869296a15ba2a147d21e4f4689bdf7fa0e8b873.zip
mark dialog-0.9_beta20031207-r1 x86, add dialog-1.0.20040731
Diffstat (limited to 'dev-util/dialog/dialog-1.0.20040731.ebuild')
-rw-r--r--dev-util/dialog/dialog-1.0.20040731.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/dialog/dialog-1.0.20040731.ebuild b/dev-util/dialog/dialog-1.0.20040731.ebuild
new file mode 100644
index 000000000000..9d158082763e
--- /dev/null
+++ b/dev-util/dialog/dialog-1.0.20040731.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.0.20040731.ebuild,v 1.1 2004/09/21 14:35:33 lanius Exp $
+
+inherit eutils
+
+MY_PV="${PV/1.0./1.0-}"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://hightek.org/dialog/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${MY_PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~macos ~ppc-macos"
+IUSE="unicode"
+
+DEPEND=">=app-shells/bash-2.04-r3
+ >=sys-libs/ncurses-5.2-r5"
+
+src_compile() {
+ export LANG=C
+ use unicode && ncursesw="w"
+ econf "--with-ncurses${ncursesw}" || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc CHANGES README VERSION
+}