summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2005-11-06 02:42:18 +0000
committerMike Gardiner <obz@gentoo.org>2005-11-06 02:42:18 +0000
commit210187cb88c2275a8cc989be32373117cf026d46 (patch)
tree96abba3f1ab75fa91e2ea57b05d2f59ed75976b0 /dev-util/desktop-file-utils
parentRevision bump; added patch that fixes the storing of locale-specific <longdes... (diff)
downloadgentoo-2-210187cb88c2275a8cc989be32373117cf026d46.tar.gz
gentoo-2-210187cb88c2275a8cc989be32373117cf026d46.tar.bz2
gentoo-2-210187cb88c2275a8cc989be32373117cf026d46.zip
Added man pages to desktop-file-utils. See bug #85354 for more, thanks to Matt Kynx for providing the man patch.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-util/desktop-file-utils')
-rw-r--r--dev-util/desktop-file-utils/ChangeLog10
-rw-r--r--dev-util/desktop-file-utils/Manifest5
-rw-r--r--dev-util/desktop-file-utils/desktop-file-utils-0.10-r1.ebuild40
-rw-r--r--dev-util/desktop-file-utils/files/desktop-file-utils-0.10-man.patch127
-rw-r--r--dev-util/desktop-file-utils/files/digest-desktop-file-utils-0.10-r11
5 files changed, 181 insertions, 2 deletions
diff --git a/dev-util/desktop-file-utils/ChangeLog b/dev-util/desktop-file-utils/ChangeLog
index 4bd4c7687171..c20b4d8733b1 100644
--- a/dev-util/desktop-file-utils/ChangeLog
+++ b/dev-util/desktop-file-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/desktop-file-utils
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/desktop-file-utils/ChangeLog,v 1.34 2005/10/10 08:12:32 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/desktop-file-utils/ChangeLog,v 1.35 2005/11/06 02:42:18 obz Exp $
+
+*desktop-file-utils-0.10-r1 (06 Nov 2005)
+
+ 06 Nov 2005; Mike Gardiner <obz@gentoo.org>
+ +files/desktop-file-utils-0.10-man.patch,
+ +desktop-file-utils-0.10-r1.ebuild:
+ Added man pages to desktop-file-utils. See bug #85354 for more, thanks to
+ Matt Kynx for providing the man patch.
10 Oct 2005; Hardave Riar <hardave@gentoo.org>
desktop-file-utils-0.10.ebuild:
diff --git a/dev-util/desktop-file-utils/Manifest b/dev-util/desktop-file-utils/Manifest
index 40f377225cb8..32e642b78595 100644
--- a/dev-util/desktop-file-utils/Manifest
+++ b/dev-util/desktop-file-utils/Manifest
@@ -1,8 +1,11 @@
MD5 47921578ef239281b0f4e10dee97d67d ChangeLog 4333
+MD5 8c2fa1a2b243bf70be4cbb14f79a372a desktop-file-utils-0.10-r1.ebuild 894
MD5 8a5a56ffb7095f0a23207e68c5a8331d desktop-file-utils-0.10.ebuild 923
MD5 a14cfd2626eb7ec319b7489be271998a desktop-file-utils-0.9.ebuild 916
-MD5 80850151bae2bd61c4ac796f83656ef6 metadata.xml 217
+MD5 bfd3e4da82cdee8b0d2f1e6b89eabdf8 files/desktop-file-utils-0.10-man.patch 4135
MD5 367c27a5e805a5ab6bbdaee8563cacf6 files/desktop-file-utils-0.10-noemacs.patch 409
MD5 a5b7ad2bec794347c2aa4fd97ccb4228 files/desktop-file-utils-0.8-noemacs.patch 417
MD5 0e35e3a36f381ec9666f47b801026825 files/digest-desktop-file-utils-0.10 75
+MD5 0e35e3a36f381ec9666f47b801026825 files/digest-desktop-file-utils-0.10-r1 75
MD5 f7113107af039bf8cf5156ecc74e62f5 files/digest-desktop-file-utils-0.9 74
+MD5 80850151bae2bd61c4ac796f83656ef6 metadata.xml 217
diff --git a/dev-util/desktop-file-utils/desktop-file-utils-0.10-r1.ebuild b/dev-util/desktop-file-utils/desktop-file-utils-0.10-r1.ebuild
new file mode 100644
index 000000000000..6042d5c20643
--- /dev/null
+++ b/dev-util/desktop-file-utils/desktop-file-utils-0.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/desktop-file-utils/desktop-file-utils-0.10-r1.ebuild,v 1.1 2005/11/06 02:42:18 obz Exp $
+
+inherit eutils
+
+DESCRIPTION="Command line utilities to work with desktop menu entries"
+HOMEPAGE="http://www.freedesktop.org/software/desktop-file-utils/"
+SRC_URI="http://www.freedesktop.org/software/desktop-file-utils/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=dev-libs/popt-1.6.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # patch that disables auto pre-compiling of emacs mode file.
+ epatch ${FILESDIR}/${PN}-0.10-noemacs.patch
+
+ # add the man pages, see bug #85354
+ epatch ${FILESDIR}/${PN}-0.10-man.patch
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ doman man/*
+
+}
diff --git a/dev-util/desktop-file-utils/files/desktop-file-utils-0.10-man.patch b/dev-util/desktop-file-utils/files/desktop-file-utils-0.10-man.patch
new file mode 100644
index 000000000000..641d795be251
--- /dev/null
+++ b/dev-util/desktop-file-utils/files/desktop-file-utils-0.10-man.patch
@@ -0,0 +1,127 @@
+diff -uNr man.orig/desktop-file-install.8 man/desktop-file-install.8
+--- man.orig/desktop-file-install.8 1970-01-01 01:00:00.000000000 +0100
++++ man/desktop-file-install.8 2005-03-15 14:56:06.000000000 +0000
+@@ -0,0 +1,62 @@
++.TH DESKTOP-FILE-INSTALL 8
++.SH NAME
++desktop-file-install \- install a desktop file to the applications directory
++.SH SYNOPSIS
++.B desktop-file-install
++.I "[options] file"
++.SH "DESCRIPTION"
++.B desktop-file-install
++installs a specified .desktop file to the applications directory,
++optionally munging it a bit in transit.
++.SH OPTIONS
++.TP
++\fB \-\-dir \fIpath\fP
++Specify the directory where files should be installed.
++.TP
++\fB \-\-vendor \fIvendor\fP
++Add a vendor prefix to the desktop file. If the file already has this
++prefix, nothing happens.
++.TP
++\fB \-\-add\-category \fIcategory\fP
++Add a category to the \fBCategories\fP field.
++.TP
++\fB \-\-remove\-category \fIcategory\fP
++Remove a category from the \fBCategories\fP field.
++.TP
++\fB \-\-add\-only\-show\-in \fIproduct\fP
++Add a product name to the \fBOnlyShowIn\fP field.
++.TP
++\fB \-\-remove\-only\-show\-in \fIproduct\fP
++Remove a product name from the \fBOnlyShowIn\fP field.
++.TP
++\fB \-\-delete\-original
++Delete the source desktop file, leaving only the target
++file. Effectively "renames" a desktop file.
++.TP
++\fB \-m, \-\-mode \fImode\fP
++Set the given permissions on the destination file.
++.TP
++\fB \-\-copy\-name\-to\-generic\-name
++Copy the contents of the \fBName\fP field to the \fBGenericName\fP
++field.
++.TP
++\fB \-\-copy\-generic\-name\-to\-name
++Copy the contents of the \fBGenericName\fP field to the \fBName\fP
++field.
++.TP
++\fB \-\-remove\-key \fIkey\fP
++Remove a specific key from the desktop file.
++.TP
++.B \-h, \-\-help
++Show summary of options.
++.TP
++.B \-\-usage
++Display brief usage message.
++.TP
++.B \-v, \-\-version
++Show version of program.
++.SH "SEE ALSO"
++The Free Desktop .desktop file specification at www.freedesktop.org.
++.SH AUTHOR
++This manual page was written by Ross Burton <ross@burtonini.com>, for
++the Debian GNU/Linux system (but may be used by others).
+diff -uNr man.orig/desktop-file-validate.1 man/desktop-file-validate.1
+--- man.orig/desktop-file-validate.1 1970-01-01 01:00:00.000000000 +0100
++++ man/desktop-file-validate.1 2005-03-15 14:56:07.000000000 +0000
+@@ -0,0 +1,15 @@
++.TH DESKTOP-FILE-VALIDATE 1
++.SH NAME
++desktop-file-validate \- validate a .desktop file
++.SH SYNOPSIS
++.B desktop-file-validate
++.I "file"
++.SH "DESCRIPTION"
++.BR desktop-file-validate
++is a tool to validate .desktop files to the Free Desktop specification
++at http://www.freedesktop.org/. It will list any errors if the file
++does not match the specification, and warnings if the file uses
++deprecated features.
++.SH AUTHOR
++This manual page was written by Ross Burton <ross@debian.org>, for the
++Debian GNU/Linux system (but may be used by others).
+diff -uNr man.orig/desktop-menu-tool.1 man/desktop-menu-tool.1
+--- man.orig/desktop-menu-tool.1 1970-01-01 01:00:00.000000000 +0100
++++ man/desktop-menu-tool.1 2005-03-15 14:56:07.000000000 +0000
+@@ -0,0 +1,37 @@
++.TH DESKTOP-MENU-TOOL 1
++.SH NAME
++desktop-menu-tool \- do stuff with menu files
++.SH SYNOPSIS
++.B desktop-menu-tool
++.I "[options] file"
++.SH "DESCRIPTION"
++.B desktop-menu-tool
++does stuff to menu files. Possibly related to the GNOME1 .menu
++files. Not sure about this. :)
++.SH OPTIONS
++.TP
++\fB \-\-dir \fIpath\fP
++Specify the directory where the compat tree should be generated.
++.TP
++\fB \-\-print
++Print a human-readable representation of the menu to standard output.
++.TP
++\fB \-\-desktop \fIdesktop\fP
++Specify the current desktop, for the purposes of \fBOnlyShowIn\fP.
++.TP
++\fB \-\-print\-available
++Print the set of desktop files used for a given menu file.
++.TP
++.B \-h, \-\-help
++Show summary of options.
++.TP
++.B \-\-usage
++Display brief usage message.
++.TP
++.B \-v, \-\-version
++Show version of program.
++.SH "SEE ALSO"
++The Free Desktop .desktop file specification at www.freedesktop.org.
++.SH AUTHOR
++This manual page was written by Ross Burton <ross@debian.org>, for the
++Debian GNU/Linux system (but may be used by others).
+
diff --git a/dev-util/desktop-file-utils/files/digest-desktop-file-utils-0.10-r1 b/dev-util/desktop-file-utils/files/digest-desktop-file-utils-0.10-r1
new file mode 100644
index 000000000000..455a664c0a55
--- /dev/null
+++ b/dev-util/desktop-file-utils/files/digest-desktop-file-utils-0.10-r1
@@ -0,0 +1 @@
+MD5 8b930e9ad08ac6b8205dd00a1d694b0c desktop-file-utils-0.10.tar.gz 341508